5

I have not managed to find a way to disable the warning No Sim Card Installed while using iPad Air without sim-card. I disabled using Mobile data in all parts of settings. I have done this now in three generation of iPads unsuccessfully. The notice window looks like this

enter image description here

How can you disable the warning No Sim Card in iPads?

2

To prevent this message you can continually keep your iPad in Airplane Mode. Whilst not recommended to be on all the time, it provides a solution. If you turn WiFi on you should have no issues using internet features and services.

  • While this works, it is not suggested to use iPad with Airplane mode turned on for eternity. – Nimesh Neema Apr 15 '18 at 10:59
  • 1
    @NimeshNeema why? – Kevin Grabher Apr 15 '18 at 11:09
  • 1
    @KevinGrabher, Airplane mode technically turn off all radio communications. With the stated solution, you are left only with Wi-Fi enabled. While can turn on Wi-Fi and Bluetooth in Airplane mode, radios like GPS still remain non-functional and thus create a potentially undesirable situation. Refer to this discussion. – Nimesh Neema Apr 15 '18 at 11:18
  • -1 if I had the rep. This doesn't make the error message go away – endolith May 24 '18 at 19:16
3

Ask Siri to "turn off mobile data". Worked for me on an iPad 4 with iOS 10.2. Found in this Apple discussion.

2

You will need a SIM card to do this. You can borrow one for a brief period.

With the correct sized SIM card, remove the SIM card holder from the iPad, using the SIM card ejector tool (one is provided in-the-box with a new iPad).

With the iPad turned on:

  1. Insert the SIM card into the holder and refit the holder into the iPad.

  2. Go to Settings app → Mobile Data.

  3. Turn off Mobile Data.

  4. Remove the SIM card from the iPad.

  5. Hold down the Power button and slide the on-screen Power Off switch and wait for the iPad to power off.

The next time you turn the iPad on, it will not look for a SIM card so will not give you the SIM card not installed notification

  • 1
    On iPhone 6 this is now Settings → Cellular → Cellular Data, but it doesn't work. "No SIM Card Installed" reappears as soon as you remove the card – endolith May 24 '18 at 19:22
0

I solved the problem with:

  1. Turn on Airplane Mode

  2. Turn on WiFi and Bluetooth

  3. Turn off Airplane Mode

  4. After this Cellular Data will be on so turn it off.


The disadvantage with this method is the fact that you can't use Cellular Data.

-1

You can tell Siri to turn off Mobile Data or turn it off in settings.

I solved the issue on my 1st-gen mini (on iOS 8.0.2) by telling Siri to "turn off mobile data" and now it just says "iPad" in the status bar, instead of "No Sim".

(Source)

  • Thanks for your answer. How does this difference from this answer? – user310476 Jan 29 at 8:22
-1

I solved the problem just by removing the sim tray. Whilst not the most practical solution the iPad wont display the warning as it cant detect if a SIM card is inserted.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .