15

I discovered this new annoying bug in El Capitan 10.11.2 running on a MacBook Pro Retina, 15-inch, Late 2013.

Sometimes when I click on the VPN icon in the menu bar, I get "VPN is not configured" despite the fact that I configured three. It is all resolved by going into System Preferences → Network, then unchecking and rechecking the "Show VPN Status in menu bar" checkbox.

Even though I can manually sort the issue each time, I would like a more robust and permanent solution.

3
  • Is there a reason you're not upgrading to a fully patched version of El Capitan? Seems like the easiest fix for this would be to upgrade to 10.11.6.... May 7 '18 at 17:02
  • 2
    Todd, you are ~2 years too late in your comment. MacOS 10.13.x solved the issue long ago. May 9 '18 at 13:45
  • 1
    The bug appears to be back with Catalina 10.15.4
    – Jimothy
    Apr 27 '20 at 18:19
1

One workaround that I found useful was to use Tunnelblick rather than macOS built-in VPN networking. Tunnelblick is open source and generally respected, and if you are able to install this software on your machine, it is a more robust and permanent solution than macOS' Networking prefpane.

1
  • As I mentioned in a comment above the issue was solved at some point by an upgrade. Aug 12 '18 at 19:39
1

This was a bug on El Capitan and it is now back with Catalina. Connecting to the VPN via network preferences also repopulates the list like toggling show/hide does, but there is no fix yet.

0

Try switching Wifi networks, and then switching back to the one you were on. Worked for me!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .