I'm using Mac mini, and bought this new bluetooth keyboard. It's not Apple production, but has Apple layout. The other keys all work except "Esc" in the left up corner. Obviously it won't be handy if this important key didn't work. How to fix it, please?

  • I'd grab Key Codes from the iTunes Store & at least test the keyboard is sending something recognisable as an Esc. Should be key code 53 / 0x35
    – Tetsujin
    Jan 10, 2016 at 17:00
  • A few questions: Can we please have a link to the keyboard? Have you made sure this keyboard's esc key works, by trying it out on another computer? Have you tried using a different keyboard, but of the same model?
    – Flare Cat
    Jan 10, 2016 at 18:35
  • Hi Tetsujin, thank you for your guidance. I've just tried Key Code, and pressed "Esc" but nothing appears on the dialogue window, while space key, number keys all work very well. Seems like the system dosn't recognize "Esc" and from "f1" to "f12". Do you know how to make them match to the system, please?
    – Kathryn
    Jan 10, 2016 at 19:08
  • I'd be tempted to take it back to the shop & swap it for a Mac-specific one. If they keyboard's not transmitting anything that Key Codes can see, then neither can the Mac.
    – Tetsujin
    Jan 11, 2016 at 8:14
  • Thank you, Tetsujin. It's bought in a supermarket, so seems not possible to swap. I need to give up on this : )
    – Kathryn
    Jan 11, 2016 at 12:00

1 Answer 1


I have (likely) the same keyboard and solved the problem this way: I mapped caps lock to esc.

You can do this via System Preferences > Keyboard > Modifier Keys. There, at Caps Lock select Escape.

Not the answer you're looking for? Browse other questions tagged .