2

Wondering if anyone has any last ditch efforts I can try here to salvage my macbook!

I recently attempted to install fedora to dual boot on my Late 2011 Macbook Pro, the install crashed, the emergency kernal crashed, got the 3 bleep black screen of death (indicating RAM does not pass data integrity check?). Now whenever I try and boot it gets to the Apple loading screen, bar goes about half way (very slowly) then grey screen and eventual power off.

Same happens if I try to boot into safe mode or recovery partition or do an internet recovery. (Tried PRAM and SMC at well)

Using fsck in single user mode highlighted file system modified (which I expected from the linux fail) cycling fsck -fy enabled me to get a "The volume appears to be OK" message, great, still no boot.

Officially out of ideas here!

Any ideas would be greatly appreciated!

Thanks,

  • 1
    I'd be tempted to think the initial crash was not the cause, but the first symptom. Have you tried Hardware Test? – Tetsujin Jan 10 '16 at 14:12
  • 1
    Not so easy on a laptop, but it's the kind of situation on a desktop, I'd be pulling the HD into a USB enclosure, dropping a virgin drive into the machine, then install an OS to the new drive & continue to test the old one from the relative safety of the external enclosure. – Tetsujin Jan 10 '16 at 16:58
  • 1
    Yeh, same but like you say, these unibody machines are a pain to pull components out of. I've just run the extended hardware test and got an error with the memory though! 4MEM/64/ ....... I guess I shall try an decipher that, you think it's worth swapping the sticks over see if that helps? – Uberzen1 Jan 10 '16 at 17:00
  • 1
    If you can tell which stick errored, pull it & test without. Assume the HD might in fact be fine - though with possibly corrupted structure somewhere - & the memory was driving the errors. If the drive can be repaired with the remaining memory, then you have to decide whether to risk putting the suspect memory back & the further issues that could cause. If you could pull the drive & work from something disposable, memory testing would be less fraught. – Tetsujin Jan 10 '16 at 17:05
  • 1
    Okay, after testing every possible configuration, I have managed to boot! I had to remove one stick so am currently running (slowly!) on 4GB. I have been able to remove the extra linux partitions and rebuild the osx one, so I know the disk is solid now. So I guess I just need to invest the £20 in a new stick to get me back up to 8GB and happy days! Thanks for the help guys! – Uberzen1 Jan 10 '16 at 21:18

You must log in to answer this question.

Browse other questions tagged .