enter image description here

I cannot open Terminal at all because of this error message. (Probably the rudest error message I have ever seen on a computer.) This mac was originally a school computer and the permission to use Terminal was not given to me in the first place, so I have no clue about the method the "IT guys" used to keep me from using it, and therefore I do not know how to recover from it either. I have an admin account, though the account I usually use is standard, (I tried logging into other existent admin accounts presumably set up by the IT guys, but even in those accounts it was impossible to run Terminal), and I have already tried running permissions repair but it had no effect on the issue.

(p.s. I am not a very advanced user of mac, so descriptions fit for a newbie would be very much appreciated. Have seen a similar question on this website but it did not really help.)

5 Answers 5


Going by the appearance of the dialog window, it looks like the school you got this Mac from was using JAMF Software's Casper Suite to manage their Macs. One of Casper's features is being able to prevent specified applications from launching, with the additional option of providing a message to the end-user. As you're receiving this message, it appears that the Casper agent software is still installed on the Mac in question. There's an uninstall command to remove the Casper agent, but that would need to be run in Terminal. The article at https://jamfnation.jamfsoftware.com/article.html?id=153 by the authors of Casper explains how this is done.

At this point, I think the best bet is to back up your applications and data, wipe the drive of the Mac, and reinstall from scratch. It's the best way to make sure everything which the school had installed is now gone.

  • problem solved by booting into single-user mode and using that command to annihilate that thing. i can't believe i got this idea months after posting this question. thanks a lot! Commented Jul 7, 2016 at 4:37

Your best bet would be to do a clean install, presuming you have copies / licenses for any software you use on there. Backup any files you want to keep, and follow one of the many guides out there. For instance:


This could well take less time than figuring out what the IT guys did, and make your Mac faster in the long run.

  • 7
    Plus, even if you did figure out how to make Terminal run normally, you'd never know what else they did to the computer. Clean reinstall's the way to go. Commented Jan 10, 2016 at 10:10
  • 8
    Yeah…there might be some spyware buried deep in the system where you'll never quite be able to get rid of it. Nuke the thing from orbit. Commented Jan 10, 2016 at 10:55

It looks as if the Terminal app was removed and replaced with an application that displays that dialog, so changing permissions won't help. Doing a clean install as BaronVonKaneHoffen suggested would work, but there are another options.

Option #1 - Restore from another Mac

If you own or have access to another Mac, you can copy /Applications/Terminal.app to /Applications/Terminal.app on this mac.

Option #2 - Restore from the Recovery Partition

(Almost?) Every Mac has had a recovery partition since Mac OS X Lion. If you turn off your computer and turn it back on while holding Command + R as described in https://support.apple.com/en-us/HT201314 you will enter the Recovery Partition. From there, you can select Utilities->Terminal to enter the Terminal. From there, you can type in (untested, something like this)

cd /Applications/Utilities
rm -rf /Volumes/Macintosh\ HD/Applications/Utilities/Terminal.app
cp -r Terminal.app /Volumes/Macintosh\ HD/Applications/Utilities/Terminal.app

Option #3 - Restore from an Apple Software Update

This is the easiest way as it can be done without rebooting or transferring files. Simply download a Terminal replacement such as iTerm (Heck, you might as well just use that instead of Terminal) and run

cd /tmp


curl -ORL http://swcdn.apple.com/content/downloads/21/09/031-20634/8d84o1ky5gn2agnf5kiz9eed134n7y3q4c/RecoveryHDUpdate.pkg

xar -xf RecoveryHDUpdate.pkg

hdiutil attach -nobrowse RecoveryHDMeta.dmg
hdiutil attach -nobrowse "/Volumes/Recovery HD Update/BaseSystem.dmg"

sudo rm -rf /Applications/Terminal.app # Erase the old Terminal app. Password required.
sudo cp -Rp "/Volumes/OS X Base System/Applications/Utilities/Terminal.app" /Applications/Utilities/Terminal.app # Copy over the new Terminal app

hdiutil detach "/Volumes/OS X Base System"
hdiutil detach "/Volumes/Recovery HD Update"

cd ~

Additionally, you can simply run curl https://gist.githubusercontent.com/lights0123/2a03d88f99fbbdfc8a35/raw/8d961db047d387319e07e56c228847394ecc1b57/Terminal.command | sh to avoid copying/pasting the above.

  • Hm, this could also be a possibility.
    – nicael
    Commented Jan 10, 2016 at 23:07

It's possible that that is actually a custom dialog box that has been redirected from terminal.app

If you can install apps, look for a terminal alternative program.


That is not an Apple error. You either have a permissions issue and the error is coming from a security script or a virus. Reinstall the OS using a Disk Utility image, and reinstall from scratch.

It's a straight forward process, let me know if you want help.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .