9

How can I disable the iMessage pop up when I turn on my Mac? It keeps asking me to sign in with my Apple ID. I don't want to set it up because I don't want to use iMessage. But the box keeps opening every time I turn on my Mac and it is getting frustrating as I have to go through 3 pages before I can turn it off.

8 Answers 8

6

I had to contact apple support for this solution. The fact that it is not intuitive implies a usability bug. The reason for the prompt is a keychain entry under either login or local items. Basically after removing all entries with the text 'apple' in them I was able to restart and login with no facetime or imessage prompts to login. I hope this helps.

1
  • Removing all of the entries found when searching for "message" in the /Applications/Utilities/Keychain Utility.app seemed to have solved it for me. These included various public/private certificates, so hopefully this will not have crippled features if I ever want to use the software - probably going through and deleting items one-by-one would have been smarter, but I am impatient.
    – j-beda
    Feb 22, 2019 at 16:11
4

iMessenger is the iOS version for iPhone/iPad etc. On your Mac, it's called "Messages". Open Messages, go to your Preferences tab in Messages. Select your Message account from the list on the left, then click on the checkbox next to Enable this account to remove the checkmark and disable your Message account on your Mac.

2
  • I don't see an "enable this account" checkbox. Maybe it's because I haven't entered the password for my apple ID, but I don't want to.
    – JWWalker
    Sep 13, 2018 at 16:41
  • 4
    I have no accounts, it keeps opening up randomly and at start up asking for my iCloud password
    – Ray Foss
    Jan 16, 2019 at 19:44
2

This is not the answer you deserve… but the answer you need an answer that works…

This did it for me:

  • Open Messages and log into it. (Every Mac user does have an Apple account, since it's required to activate the OS on install, no?)
  • In the Messages preferences, log out.

Result: no more annoying popup asking me to log in on reboot.

This is about as intuitive as Windows 95 gets, but please don't blame the… messenger.

(FYI, I have no iCloud info set inside of System Preferences, and Settings > General > Handoff & Suggested Apps is ticked off. But these, on their own, were not enough.)

1

On your Mac go to  > System Preferences > General and disable option Allow Handoff between this Mac and your iCloud devices

OR iPhone go to Settings > General > Handoff & Suggested Apps and dislable Handoff

1
  • 1
    Did this, no change
    – Ray Foss
    Jan 16, 2019 at 19:45
1

I had the same problem, iMessage kept asking me to sign in every time I logged in on my Macbook. The pop-up mentioned my e-mail address so it must have stored some personal data at one point. However I never signed in to iMessage, iCloud, iTunes or other Apple cloud services on this device or on other Apple devices.

Finally I searched for files that contain the e-mail address and ended up deleting ~/Library/Preferences/com.apple.identityservicesd.plist. YMMV and proceed at your own risk, but it worked for me!

[dirk] For me it worked as well. Since I favour renaming files over deleting them, I did

mv ~/Library/Preferences/com.apple.identityservicesd.plist ~/Library/Preferences/com.apple.identityservicesd.pl-dis-ist

Then I signed off and on again. The prompt did not appear anymore.

Now I renamed the file back

mv ~/Library/Preferences/com.apple.identityservicesd.pl-dis-ist ~/Library/Preferences/com.apple.identityservicesd.plist

plus signed off and on again. And, - surprise surprise - the prompt still did not show up.

Since the file content now is again like it was before, that may minimise some fear of getting into general trouble loosing your stored identities.

0

You can disable it through the Preferences in iMessenger app in your Mac. Follow this link

3
  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. Also, the Mac app is called Messages.
    – Tetsujin
    Jan 10, 2016 at 11:44
  • Thank you everyone for the answers but it still didn't solve my problem. I think I wasn't clear about my intention. I just replaced my old iMac . The new one is using El Capitan while my old one was Snow Leopard. I don't want to use iMessage and so didn't set it up. But every time I turned my Mac on, the iMessage popped up and asked me to set it up - has two buttons .. either 'sign in' or 'not now'. I have no other choice. I clicked 'not now' and other windows popped up which said 'are you sure you want to skip iMessage set up?'
    – C.K
    Jan 12, 2016 at 4:27
  • I want to disable this set up process which keeps appearing every time I turned on my iMac.
    – C.K
    Jan 12, 2016 at 4:38
0

Open messages app then click on the Messages tab located at the top left of your screen. Then click quit messages. This should fix your problem. Hope this helps.

-1

On your Mac, right-click on the Messages icon, then select options and unselect Open at login.

6
  • What? Right clicking Messages.app produces a menu that does not include "options".
    – JWWalker
    Sep 13, 2018 at 16:39
  • Did you try restarting your Mac ? Sep 14, 2018 at 17:03
  • I have restarted since then, and there is still no such item on the right-click menu for Messages. This is High Sierra, by the way.
    – JWWalker
    Sep 14, 2018 at 20:25
  • Sorry, I misread your question. I think going on settings and turning off iMessage should resolve your problem Sep 16, 2018 at 10:07
  • Even though I don't want to use iCloud, I logged in with it for the sake of finding out… and there's no option about opening at login in the Messages settings. Nov 4, 2019 at 13:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .