2

When I close my Retina Macbook Pro's lid and put it to sleep, I have noticed that it periodically must "wake" and check the internet or connect to Wi-Fi when I expect it to be sleeping. This has been consistent for me even with my previous MacBook Pro, too.

I see this because my Gmail tab in Chrome will have new emails preloaded, before the Wi-Fi connection is reenabled. Or when I have an IRC client open, I'll see multiple join/disconnects in the log.

pmset -g sched does not print anything.

How can I stop it from doing this?

  • 4
    Try disabling Power Nap support.apple.com/en-us/HT204032 – Arc676 Jan 8 '16 at 13:45
  • 1
    Before enable the sleep mode turn off Wi-Fi connection. – Mattia Jan 8 '16 at 13:49
  • @Mattia This is, at best, a workaround. It's certainly no fix. – Max Ried Jan 8 '16 at 13:50
  • @enderland Could you add the output of pmset -g sched? – Max Ried Jan 8 '16 at 13:50
  • @MaxRied done. Arc that seems promising... – enderland Jan 8 '16 at 13:57

You must log in to answer this question.

Browse other questions tagged .