1

After I export my GarageBand song and convert it to an mp3 and play it in iTunes, the background static noise is much louder than in Garageband.

OS X El Captain 10.11.2 . Garageband 10.1.0

I want it to sound the same as it does in GarageBand.

How can I convert tracks into an mp3 while reducing static noise in the file when played on iTunes?

  • What are the precise/exact steps you use to convert to mp3? Also, what version of OS and GarageBand are you using - there are quite a few and the ways to post-process a track vary widely across versions and platform. – bmike Jan 7 '16 at 22:19
  • I 'export song to disk' under 'share'. I select mp3, medium quality. OS X El Captain 10.11.2 . Garageband 10.1.0 – Rob Wynn Jan 8 '16 at 14:22
  • I chatted with Apple and they suggested downloading Audacity and using Effects to reduce the static noise. I have done this and it is much better now. If anyone else has the same problem use the 'Notch Filter' first, then 'Noise Reduction' - Noise Reduction: 6, Sensitivity: 1, Frequency Smoothing: 0. You can try different settings but these worked for me. – Rob Wynn Jan 8 '16 at 17:14
  • Great work - I've added this detail to the post. Why not answer this in the answer section - you will help lots of people searching to know this question has an answer... – bmike Jan 8 '16 at 20:09
  • I'm dealing with the same nightmare trying to export mp3 files for audible.com . I spoke to a sound engineer at Warner Bros where my wife works. He suggested lowering the compressor threshold to -10 dbs to remove that increase in extraneous noise which I couldn't hear at all when editing in garageband. He said if that failed that it might be the encoding, and suggested trying another program to convert the files to mp3. I totally sympathise with this maddening problem. I haven't tried the fix yet, but have high hopes. Good luck!!! – Jon Jul 11 '17 at 16:09
1

I suspect this is not a file compression issue but rather an audio compression issue. By default, GarageBand has "Auto Normalize" turned on (Preferences > Advanced). This reduces the volume difference between the softest and loudest sounds in the mix on export, so that the playback of the finished audio is louder. The problem is, when you've got quiet background noise in your source files, normalizing will make it louder. Try turning off "Auto Normalize" and exporting again. The file format shouldn't matter.

Of course, the Jedi master-level fix for this problem would be to get a better recording (or better recording equipment) and to EQ/filter out the noise while mixing!

0

I chatted with Apple and they suggested downloading Audacity and using Effects to reduce the static noise. I have done this and it is much better now. If anyone else has the same problem use the 'Notch Filter' first, then 'Noise Reduction' - Noise Reduction: 6, Sensitivity: 1, Frequency Smoothing: 0. You can try different settings but these worked for me.

-1

In GarageBand change the master volume of the whole song not just the individual instrument volume, I have had the same problem as you before and it works.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.