I seem to be having a weird issue on OS X Yosemite (10.10.5) - When I have my wifi connection set to DHCP, everything works fine. But, when I switch to manual IP (even with the exact same IP config that I get from DHCP), routing to internet sites fails. I can ping local computers, but, pinging other sites results in "No route to host". I would appreciate any ideas on how to fix this. Thanks

Edit: The routes that I have after setting a manual ip are

Routing tables

Destination        Gateway            Flags        Refs      Use   Netif Expire
default        UGScI           1        0     en1
127                UCS             0        0     lo0          UH              8     2206     lo0
169.254            link#5             UCS             0        0     en1
192.168.2          link#5             UCS             7        0     en1        a0:63:91:2:9e:b0   UHLWI           0       88     en1   1195        74:d4:35:94:ef:54  UHLWIi          5      302     en1   1140        9c:20:7b:c8:9d:f7  UHLWIi          1        0     en1   1188       64:27:37:e7:24:51  UHLWI           0        9     en1   1141      28:c6:8e:5f:de:82  UHLWI           0       84     en1   1140      0:11:32:b:b9:11    UHLWI           0       14     en1   1140   link#5             UCS             1        0     en1      link#5             UHLWIir         2        0     en1   link#5             UCS             0        0     en1      ff:ff:ff:ff:ff:ff  UHLWbI          0       24     en1
  • I'd just switch it to DHCP + manual address, then the DHCP server is still in charge.
    – Tetsujin
    Jan 7, 2016 at 12:26
  • I actually need to use a different router/gateway than the main one which does the DHCP. However, any kind of manual setting - even with router as the main DHCP one - fails
    – georgemp
    Jan 7, 2016 at 12:28
  • 2 routers on the same subnet?
    – Tetsujin
    Jan 7, 2016 at 12:46
  • Only one does DHCP. The other is a Linux VM that uses a VPN to connect to the internet. Other devices don't have an issue connecting to either
    – georgemp
    Jan 7, 2016 at 13:05
  • The Linux VM is on a different machine
    – georgemp
    Jan 7, 2016 at 13:17

1 Answer 1


Looks like I am affected by the issue posted here. The proposed solution of adding a new default route works. If anybody else, has a better solution, where I don't have to do that everytime - when I switch between DHCP and Manual - I would love to try it. Thanks

Solution posted there is to add a default route to the router IP

sudo route add default 192.168.x.x

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .