2

I've saved a file with the name filename\.svg and it didn't appear in finder. When I check terminal, there was a file named .svg in the folder I saved my file. I changed its name to test.svg but it still doesn't appear in Finder. Here is a screenshot from terminal:

Terminal ls output

How can I make this file visible in Finder?

3

In order to make only this specific file visible in Finder, try the following command using Terminal.app from Applications > Utilities:

$ cd /path-to-folder/where/invisible-file/is-located/
$ chflags nohidden ./test.svg

Hope this helps

  • Nice. I was just about to add that to my answer. – Aaron Jan 7 '16 at 16:57
  • 1
    There is no need to use sudo for chflags. Except for the target file permissions. – Hamid Rohani Jan 7 '16 at 23:51
4

From this tutorial on MacWorld, here is a way to show hidden files in the Finder:

Open a terminal, and enter this command at the Bash prompt:

$ defaults write com.apple.finder AppleShowAllFiles YES

Then restart the Finder with the following command (also from terminal):

$ killall Finder

The next time you open a Finder window, your hidden files should be visible.

To echo what Oliver said, you can also use chflags to alter the "hidden" property on a specific file. (chflags man page)

chflags nohidden hiddenfile.ext
0

I think it is a bug in Finder. To make that file visible you need to re-start the finder as follows:

Press COMMAND+OPTION+ESC then select Finder and click on Relaunch.

New contributor
Hacklavya is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .