1

Last weekend my iMac started to act in a very strange way. While I was working, my Mac was very slow and the mouse and keyboard didn't respond very well.

So I decided to reboot because having two users and switching from time to time, the memory could be the problem. But when I rebooted the other user was gone, and the Mac still was very slow. I rebooted several times and nothing changed, so I decided to try to reinstall El Capitan which was the latest version that I have - originally the Mac came with Maverick.

Then everything went wrong, the system couldn't complete the installation, I tried to erase the disk, I tried to repair the disk and several errors occurred, To make this story short, I finally succeeded installing Maverick, but then I realized that it was installed in the 122.33 GB Apple SSD because the 3TB Fusion drive couldn't be formatted. Trying several time, the disk was finally erased and I ran several verification and repair passes and everything looks OK according to Disk Utilities.

But Mavericks is still installed in the 122.33 GB Apple SSD and it looks like the 3TB Fusion drive can't be recognized, partitioned or deleted, so I am very desperate.

Here are the screenshots:

enter image description here

enter image description here

I already followed this instructions here, but they didn't work. I don't recall the message but it didn't work

I hope somebody can help me, I am not under warranty and I have two Times Capsules back ups, so I don't care about the information.

  • I tried that option but it didn't work, – pepesanti Jan 8 '16 at 23:31
  • @bmike I don't think the question is a complete duplicate. The problem in the linked q&a was the BootCamp install and a small EFI partition in the middle of the disk. The solution would have been much simpler here (but only if both drives aren't damaged). – klanomath Jan 11 '16 at 19:21
  • @klanomath Sounds good - let's open this up, then... – bmike Jan 11 '16 at 20:46
1

I would suggest following the steps in the answer posted here

Most importantly: diskutil cs create "Macintosh HD" disk0s2 disk1s2

Your diskutil output should look more like this with the "logical volume"

$ diskutil list
/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *121.3 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:          Apple_CoreStorage                         121.0 GB   disk0s2
   3:                 Apple_Boot Boot OS X               134.2 MB   disk0s3
/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk1
   1:                        EFI EFI                     209.7 MB   disk1s1
   2:          Apple_CoreStorage                         999.3 GB   disk1s2
   3:                 Apple_Boot Recovery HD             650.1 MB   disk1s3
/dev/disk2
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                  Apple_HFS Macintosh HD           *1.1 TB     disk2
                                 Logical Volume on disk0s2, disk1s2
                                 D11BC089-D75D-4239-AB60-4293803F5F6D
                                 Unencrypted Fusion Drive

And Core Storage list like this:

$ diskutil cs list
CoreStorage logical volume groups (1 found)
|
+-- Logical Volume Group 56F5527E-528E-4FD2-A978-6BDB501423F5
    =========================================================
    Name:         Macintosh HD
    Status:       Online
    Size:         1120333864960 B (1.1 TB)
    Free Space:   0 B (0 B)
    |
    +-< Physical Volume 1CA60BDE-CFCA-414B-A429-B838AD39EA82
    |   ----------------------------------------------------
    |   Index:    0
    |   Disk:     disk0s2
    |   Status:   Online
    |   Size:     120988852224 B (121.0 GB)
    |
    +-< Physical Volume D730D88C-C673-4284-9A91-1B8E705FA5F2
    |   ----------------------------------------------------
    |   Index:    1
    |   Disk:     disk1s2
    |   Status:   Online
    |   Size:     999345012736 B (999.3 GB)
    |
    +-> Logical Volume Family B1CF5519-AC85-4259-9F1F-642EFD4D8B31
        ----------------------------------------------------------
        Encryption Status:       Unlocked
        Encryption Type:         None
        Conversion Status:       NoConversion
        Conversion Direction:    -none-
        Has Encrypted Extents:   No
        Fully Secure:            No
        Passphrase Required:     No
        |
        +-> Logical Volume D11BC089-D75D-4239-AB60-4293803F5F6D
            ---------------------------------------------------
            Disk:                  disk2
            Status:                Online
            Size (Total):          1111826382848 B (1.1 TB)
            Conversion Progress:   -none-
            Revertible:            No
            LV Name:               Macintosh HD
            Volume Name:           Macintosh HD
            Content Hint:          Apple_HFS
  • I already try this options but it didn't work, so my option was to delete de Core Storage, and try to start from scratch, so I did it and now I am see two drives the top one is Internal Drive Capacity 3.12 TB and the other is Macintosh HD with 3.12 TB Capacity too, but it that fine? Now I will restore all my information from my Time Machine. cross fingers – pepesanti Jan 8 '16 at 0:00
  • Update, I still have problem, after errase de Fusion Drive and fixed it with Disk Utility, I was able to download the OS X, but when the systems tried to install, it saids "INSTALL FAILED OSX could not be installed on your computer OSX can't be installed on your computer on the disk Macintosh HD, because a recovery system can't be created.Visit www.apple.com/support/no-recovery" So I checked again the internal Drive and pop up an AFI error, please help – pepesanti Jan 8 '16 at 23:35
1

Depending on the history of your Fusion Drive the following diskutil list result:

diskutil list
/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *120.0 GB   disk0
   1:                        EFI                         209.7 MB   disk0s1
   2:                  Apple_HFS SSD                     119.7 GB   disk0s2
   3:                 Apple_Boot Boot OS X               134.2 MB   disk0s3
/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *3.0 TB     disk1
   1:                        EFI                         209.7 MB   disk1s1
   2:          Apple_CoreStorage                         3.0 TB     disk1s2
   3:                 Apple_Boot  Recovery HD            650.0 MB   disk1s3

usually indicates that the CoreStorage Logical Volume Group got corrupted or a Logical Volume is missing. Otherwise you would have an additional disk:

/dev/disk2
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                  Apple_HFS HDD                    *3.0 TB     disk2
                             Logical Volume on disk1s2
                             F7C46A1C-6701-4115-AEA3-C55106875F1D
                             Unencrypted

In case of a corruption entering diskutil cs list reveals something like this then:

diskutil cs list
CoreStorage logical volume groups (1 found)
|
+-- Logical Volume Group 3A3D2012-091B-4C5B-A245-EC6EDF098AFE
    =========================================================
    Name:         HDD
    Status:       Initializing
    Size:         2999174897664 B (3.0 TB)
    Free Space:   -none-
    |
    +-< Physical Volume ADB774DB-13DA-4644-BC02-E447E49150F8
    |   ----------------------------------------------------
    |   Index:    0
    |   Disk:     disk1s2
    |   Status:   Checking
    |   Size:     2999174897664 B (3.0 TB)
    |
    +-< Physical Volume 5EE639D1-D69D-4110-B01E-7A8E11CEE18A
    ----------------------------------------------------
    (No properties)

In this case neither removing a/the missing Physical Volume with diskutil cs removeDisk pvUUID (with pvUUID: UUID of the missing Physical Volume) nor deleting the Logical Volume Group with diskutil cs remove lvgUUID help.

All content of the volumes will be erased. So backup or save any available data first.

You have to remove the whole partition with

diskutil umountDisk /dev/disk1
sudo gpt -r show /dev/disk1
sudo gpt remove -i 2 /dev/disk1

and re-add it with

sudo gpt -r show /dev/disk1
sudo gpt add -b StartBlock -i 2 -s size -t 48465300-0000-11AA-AA11-00306543ECAC disk1

in the empty space of disk1

Example:

sudo gpt -r show /dev/disk1
       start        size  index  contents
           0           1         PMBR
           1           1         Pri GPT header
           2          32         Pri GPT table
          34           6         
          40      409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
      409640  5857763472         
  5858173112     1269536      3  GPT part - 426F6F74-0000-11AA-AA11-00306543ECAC
  5859442648           7         
  5859442655          32         Sec GPT table
  5859442687           1         Sec GPT header

Re-add the partition:

sudo gpt add -b 409640 -i 2 -s 5857763472 -t 48465300-0000-11AA-AA11-00306543ECAC /dev/disk1

Unmount the disk and create a new file system:

diskutil umountDisk /dev/disk1
sudo newfs_hfs -v "HDD" -J /dev/disk1s2

Verify (and repair if necessary) the disks and the volumes:

diskutil verifyDisk disk0
diskutil verifyDisk disk1
diskutil repairDisk disk0
diskutil repairDisk disk1
diskutil verifyVolume disk0s2
diskutil verifyVolume disk1s2
diskutil repairVolume disk0s2
diskutil repairVolume disk1s2

Now you should be able to continue recreating a Fusion Disk:

diskutil cs create disk0s2 disk1s2
diskutil cs addVolume lvgUUID jhfs+ "Macintosh HD" 100% #lvgUUID: the UUID you got in the previous step

This might fail if one or both of the disks are physically corrupted.

-1

I'm sure you resolved this by now, but here's a follow up for anyone else. I believe there may have been a bad batch of Fusion drives. I had the same problem described with the same model. The problem is the HDD of the Fusion drive failed and it simply needs to be replaced.

AppleCare will cover this though. Take advantage of it, if you have it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .