3

Whenever I try to reply (or reply all) to any email through the mail app, an empty new message window opens that I can type in but all the buttons (send, attach etc.) are greyed out and I cannot close the window without restarting the mail app. Has made the app complete unusable except for reading emails. Any ideas how to fix this?

  • Sending new mails (not replies) works? Do you have any Mail plugins installed? – nohillside Jan 6 '16 at 12:06
  • Sending new mails works without a problem. Not using any plug-ins either – rob Jan 6 '16 at 15:39
1

In my case the following approach has fixed this issue, for the time being at least:

(Using Mail.app version 9.2)

Go to Mail > Preferences and select the 'Composing' tab. In the section of preferences relating to 'Responding' and change the settings so that they are the opposite of what you normally use. Save the changes.

I then quit Mail. (In my case I then restarted the machine as well - for a wholly separate and unrelated reason, but I don't know if that's a critical step or not, certainly won't do any harm.) Re-launch mail, and I found that replying to a message now conforms to the new preferences that I've set.

I then re-edited the preferences to set them back to what I wanted. Tried a new reply, and it works - the target addresses are in place, the text of the original is there and quoted.

I guess the issue may have been due to the original preference settings getting corrupted in some way. I'll keep it under review, and if it stops working again anytime soon, I'll aim to add a comment here.

  • unfortunately didn't work. still just opens blank windows that cannot be closed – rob Jan 20 '16 at 11:50
  • This worked for me. The restart did seem to be important. I wonder if flushing the defaults cache might do it as well. – Ben Lachman Apr 1 '16 at 17:30
0

Sounds like that you're outgoing mail server has been changed.

  • Go to Mail Preferences
  • Select the account you're having problems with from the list. Click the 'Account Information' > In the 'Outgoing Mail Server (SMTP)' section, select 'Edit SMTP Server List' from the dropdown menu.
  • Make sure your username, password and server is correct and Click the "Advanced" button and deselect "Automatically detect and maintain account settings"
  • Save
  • Choose Window > Connection Doctor.
  • Thanks for the advice, but it won't let me deselect "automatically detect and maintain account settings". This is happening with all my accounts at the moment. – rob Jan 6 '16 at 13:10
  • Please double check your server credentials. Also do see any red errors in the Connection Doctor (In Mail choose Choose Window > Connection Doctor – howdytom Jan 6 '16 at 14:36
  • No problems at all, all of them are green. What is the best way of going about checking server credentials? I do receive emails without a problem and can compose and send a new one. This issue only occurs if I press reply to any email. – rob Jan 6 '16 at 14:49
  • Okay, That’s good. Than you might try to reset your Mail Preferences. Keep in mind this will reset Mail to the factory settings!! You can keep the old preferences in case you would like to go back. Quit Mail Switch to Finder > Go to > Library Move the following items/folders to the Desktop or Trash Caches/com.apple.mail Preferences/com.apple.mail.plist Open Mail and check again – howdytom Jan 6 '16 at 16:45
  • Thanks. I can't seem to find anything relating to com.apple.mail in the Cache folder in the library, only in the preferences folder. I deleted the plist file (though it was last modified in november 2013). After reopening it seems to be working fine for now though so finger crossed(?) – rob Jan 7 '16 at 11:15
-1

The workaround that I have found is to restart and can send replies as normal but the problem will return back soon after.

You must log in to answer this question.

protected by Community May 15 '16 at 18:13

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .