1

I have downloaded the latest Xcode 7.2 from the App Store.

enter image description here

But when I open Xcode, it still show the version as 6.4.

enter image description here

I am running on OS X Yosemite 10.10.5.

How do I use Xcode version 7 and above?

1

Unfortunately, I got the same problem some times ago, when, after upgrading to El Capitan, I couldn't update to Xcode 7.1.1.

To solve this issue, I did the following:

  1. Remove the .app file in your Application folder (if you prefer, you can use apps like CleanMyMac to remove any other related files);
  2. Go to Downloads for Apple Developers (after having logged in) and download Xcode 7.2 directly from there.

Don't know exactly why the normal update doesn't work, but now, after re-installing the app completely, everything works fine for me (also the new updates from the App store).

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .