6

I can successfully add Time Machine exclusions using tmutil addexclusion and I can verify exclusions successfully with tmutil isexcluded but if I then open up Time Machine's Preferences and click "Options..." none of the exclusions added via tmutil are listed.

  • Use of the -p option when using tmutil addexclusion seems to make no difference.
  • Restarting the OS makes no difference.
  • Re-indexing Spotlight makes no difference.

I've tested this on both Mac OS 10.9 and 10.11.

Is this expected behaviour?

1
  • I can confirm that they do show up when using -p these days. Tested on 10.15.4 (Catalina). It's necessary to give Terminal "Full Disk Access" in the "Security & Privacy" panel.
    – nschum
    Mar 29, 2020 at 14:29

1 Answer 1

4

Aaah, the following page seems to suggest that this is in fact expected behaviour:

http://pondini.org/TM/Works4.html

Exclusions Not Shown on the Preferences Window

Fixed Path Exclusions are set by the CSBackupSetItemExcluded API or sudo tmutil with the -p option, whether the item exists or not.

Sticky exclusions are set in an item's extended attributes, via the CSBackupSetItemExcluded API, xattr, or tmutil without the -p option.

3
  • Here is a link to a related answer about how to set up exclusions: apple.stackexchange.com/a/272563/23555
    – Traveler
    Feb 23, 2017 at 19:20
  • @Traveler From what I can tell that post just discusses how to use globbing to add multiple exclusions. It doesn't mention anything about whether the excluded paths are visible via the Time Machine preferences GUI once added (which is specifically what my original question is about).
    – danbohea
    Feb 24, 2017 at 8:46
  • True, it is related but not the same. To solve my problem required understanding both topics so I linked it.
    – Traveler
    Feb 24, 2017 at 14:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .