I have a MacBook with a 120 GB SSD. I bought a new one with 240 GB. I cloned the content from the old one over with an ICY BOX cloning device. I inserted new SSD in the MacBook and everything is fine and works. But I then noticed in the disk utility that the size of the partition is still the old one (120 GB).

So here is what I have tried so far:

  1. I dragged the partition in the pie chart to use all unlocated available space. But then I get the error from MediaKit: "Error: -5341: MediaKit reports partition (map) too small".

  2. I ran GParted on a USB flash drive, mounted it and gparted noticed some errors with the partition. it immediatly repaired it. Then I tried to increase the partition within GParted. But this was not possible. GParted can't increase HFS+ format. But after repairing it with GParted, disk utility does not show free space any longer. enter image description here

  3. I ran Terminal and diskutil resizeVolume. But it breaks up with an error message: "Error obtaining partition map size information" diskutil list

And now I am completely lost. What’s wrong and what can I do to reclaim the additional space?


5 Answers 5


In general, when you use those hardware-only cloning devices—like that ICY BOX you mention—you end up in situations like this. Perhaps there is a cleaner way to recover from a situation like this, but in my experience what you are attempting to do just won’t work; hardware cloning like that is strictly one-to-one as far as volume size goes. And if the target volume size is larger than the source size, the situation that you are in happens; the volume is cloned but the maximum destination volume size becomes exactly the same as the source volume size.

What I always do for cases like this—cloning smaller drive to larger drive—is to hook up the new drive to the machine in some way (such as an external USB enclosure) and then clone it via rsync or Carbon Copy Cloner. This strictly copies OS level data from one device to another; not partition data/info so this always works right off the bat.


If you clone a disk with APFS containers to a larger disk, you'll need to repair the partition before trying to resize the container. I found the answer posted by user @Ilya-K in this thread https://apple.stackexchange.com/a/390791/394570

basically, diskutil list to get a list of disks. Find the disk you want to edit, usually disk0 in a single disk system. Then diskutil repairdisk disk0 and you'll get a warning about potential data loss, but since this is a clone, you should be safe. If this is not a clone, backup first. This will repair the partition map so it see the entire new disk. Then resize the APFS container with diskutil apfs resizeContainer disk1 0 where disk1 is the APFS container shown from the diskutil list command, and 0 means use all remaining available space.

  • Old comment but this worked perfectly for me. I setup a virtualbox with mac with hard disk too small to install xcode (which now requires 40GB+ free) Feb 4, 2021 at 18:13

So I recently did the exact same thing. Copied my 250gb hdd to a new 500gb ssd and found 250gb of unallocated space. I tried using disk utility to resize and it would resize it, but would give an error and actually end up resizing the recovery partiton instead. I finally figured out that if you reformat the unallocated space to hfs+ through a bootable usb stick of gparted and then go back to disk utility ( I did it on another mac with the new drive externally plugged in) it will then let you resize the main partition to use the full size of the disk. Hope this helps


I just had to say the last comment by Wes helped me. Spent ages trying to fix unallocated space. Same deal as Wes. Copied my 250GB HDD to a new 500GB SSD and found 250gb of unallocated space. Tried using disk utility as well. I tried for ages to create a gparted boot USB but failed. What worked for me is that I created a Parted Magic boot USB on Windows using Rufus. Then as Wes said formatted the unallocated space to HFS+. Booted normally and voila disk util extended fine. Thanks Wes!

  • Mac users can create a PartedMagic USB without the need for a Windows machine using the DD command in Terminal. This is well-covered elsewhere but essentially find the USB disk ID in Disk Utility (e.g. Disk2) and ensure it’s unmounted. Type (excluding quotes) “sudo DD bs=1m if=“ then drag the .ISO image to the Terminal window to automatically enter its path. Continue and finish the command with “of=/dev/rdisk2”, substituting the disk number for the actual ID of the USB, “2” used here as an example. Use “rdisk” (raw disk) in preference to just “disk” as it’s significantly faster. May 13, 2021 at 11:00

I ran into a similar problem after deleting my Linux partition on an old MacBook Pro running 10.6. I couldn’t expand the OS X partition to fill the newly empty space no matter what I tried. Disk Utility always gave the “MediaKit reports partition (map) too small” error, and GParted isn’t capable of expanding HFS+ partitions. Wes and Moff’s answers helped me too. Here is what I did:

I booted to a GParted live USB and created a new HFS+ partition in the unallocated space (Disk Utility wouldn’t let me do it). Then I booted back into OS X and ran these commands (disk0s2 is my OS X partition, disk0s3 is the new empty partition named “Empty Partition”):

diskutil eject "/Volumes/Empty Partition"
diskutil mergePartitions HFS+ "Macintosh HD" disk0s2 disk0s3

Worked fine even with me booted into the volume I was expanding.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .