1

Display of problem here: https://www.youtube.com/watch?v=lU_d1P-qX1s (10 seconds long)

I'm a developer and have all sorts of programs installed, including SourceTree and GitHub's desktop app. Unfortunately, in the last few days, since upgrading to El Capitan this continues to happen to me.

When I'm working, or just using the computer at all, a credentials question pops up front and centre, asking me if I want to allow git-credential-sourcetree access to github.com in my keychain, full message

git-credential-sourcetree wants to use your confidential information stored in "github.com" in your keychain.

Do you want to allow access to this item?

Always Allow | Deny | Allow

My first click, and preference is Always allow, but if I click that, or Allow, nothing seems to happen. Only when I click Deny does the prompt seem to take on board what my choice is. After I click Deny, the popup disappears, but always pops up once more, and only stays away if I click Deny again, as shown in the clip.

It's really distracting and irritating, especially given that I really do want SourceTree to be able to access that login information (SourceTree was the original program I inputted my login information for Github).

  • Same issue here - but no MagicPrefs – user174895 Mar 10 '16 at 22:59
2

I've received the answer to my problem from finchr's post at https://discussions.apple.com/message/29270520#29270520,

In my case the problem was with MagicPrefs, a utility that lets you define additional mouse and trackpad gestures. Disabling MagicPrefs allows Keychain to see Allow/Allow All mouse clicks.

Which was the very same for me. I haven't permanently disabled, or uninstalled MagicPrefs, I just disable it when I need to click one of those boxes. Hopefully they or Apple will come out with an update that fixes this.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .