2

I verified the integrity of my Macintosh HD (MacBook Pro 13" 2012, OS X Yosemite) with Disk Utility when I was logged in as a user and it reported this problem:

Invalid volume free block count
...
Error: This disk needs to be repaired

Then a window popped open and said that I had to repair the disk with the Disk Utility in Recovery Mode (cmd+R immediately after restarting the Mac). But when I do this, it doesn't find an error, so when you press the 'repair disk' and you check the disk in single mode once again, the error isn't changed.

Update: What I see, when I open User Single Mode:

User Single Mode Screenshot

Update 2: The solution worked, disk utility also doesn't generate an error anymore: Solution worked

  • Nothing in the image you posted seems incorrect in single user mode. Could you make an edit below the image to type which lines you feel are the error message? Or run the /sbin/fsck -fy and post an image of the error message you see in single user mode? – bmike Jan 5 '16 at 13:45
  • I'm new to Single User Mode, so I just posted this image to know what I need to do in this mode :) – Simon Ravelingien Jan 5 '16 at 13:50
2

Here's a beginner's guide to the command line. The single user mode is also like looking in as root - the first user that owns all of the computer historically from a unix perspective.

the $ indicates a prompt where you, the human user can type commands. The system is telling you how to prepare the drive for running the repair command.

Type the following text - the same as the first line you are told to from the screen:

/usr/sbin/fsck -fy

Note, that every space, every punctuation is exact and changing any one item may run an entirely different command. If the fsck command has any errors, you can and should run it again with the same command up to three times in a row or more in some rare cases.

To get out of that screen, you could halt the Mac or type exit to resume the normal start up process.

Apple documents the root user and fsck in these two articles if you are curious or wish to learn more:

  • 1
    Thank you, it worked. Do you have any idea why Single User Mode could fix this and Recovery Mode not? – Simon Ravelingien Jan 5 '16 at 17:38
  • Yes @SimonRavelingien - some times you need to fix larger errors and the second run fixes the rest of the errors. If you repeated the check on Recovery - you likely would have no different results. The second run almost always succeeds. Single user runs the same basic check as recovery - so it's extremely unlikely one would be different even though recovery has a lot more running before you start the filesystem check. – bmike Jan 5 '16 at 17:45
0

It looks like your OS is not the same version as the Recovery partition, so you have to repair the disk manually.

Try this:

  • Power on your Mac and boot into Single User Mode by pressing and holding cmdS until you see a black screen with status messages.
  • When in Single User Mode, check your disk:
This should show you the errors you saw before.
# /sbin/fsck -fy
Remount your harddisk in read-write mode:
# /sbin/mount -uw /
Repair the filesystem.
# /sbin/fsck -fy

The error should now be gone.

  • What do you mean with 'on power'. Do I need to hold the power button too? When i try the cmd + s combination, I get a window to reset my password – Simon Ravelingien Jan 5 '16 at 11:30
  • I meant "Power on your Macbook and after the tone keep pressing CMD-S until a black screen occurs." :-) – Garex Jan 5 '16 at 12:04
  • I managed to open Single User Mode (weirdly, it opened after I had to login on the normal login screen). I added a screenshot of what I see when I open this mode in my question. Do I now need to enter these three lines you described in your answer? – Simon Ravelingien Jan 5 '16 at 13:43
  • @SimonRavelingien No - you don't need to run the mount command since you aren't writing to the filesystem and don't want it mounted in write mode before you run the check. – bmike Jan 5 '16 at 13:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .