4

When I click on "Show password:" and enter password then click "Allow" button, then my cursor just keep loading and password does not show.

a busy cat

Keychain looks like it's frozen, only "Deny" button works which will close the window. Same problem with old and new saved passwords.

This happened two months ago after I have upgraded to OS X El Capitan. New Keychain and reset did not help.

2

I had the same problem when using my wacom tablet with the Keychain. When using an actual mouse the problem does not occure. I found the following post that explained this problem in detail:

With the 10.11.1 update, Apple introduced a "security fix" that disabled the ability for non-physical devices to interact with the Keychain. You can see the details of this "fix" here (scroll all the way to the bottom of the page and look for CVE-2015-5943 for a full description):

About the security content of OS X El Capitan v10.11.1 and Security Update 2015-007 - Apple Support

You can confirm this being the issue with your machine if you view the system logs via the Console.app. When you click on "Always Allow", you should see the following in the logs:

Ignoring user action since the dialog has received events from an untrusted source

Basically, your click is being registered as a "synthetic click". In my case, this was because I was using Apple Remote Desktop (I also tested various other remote apps I use, like TeamViewer and iTeleport Connect, and all resulted in the same error in the logs).

So a solution to this problem is to use a physical mouse to interact with the Keychain.

  • @W. van Kuipers I am having the same issue, but I am already using a "regular" mouse, the Apple Magic Mouse, and/or the built-in touchpad of my Mac, and working directly on the Mac, no RDP. And I still get the same error message in the system.log about "untrusted source". Do you have any additional idea? – Mathias Conradt Mar 21 '16 at 21:37
  • @MathiasConradt Have you tried it without the mouse attached to your Mac? Do you have any other (touch) devices connected to the machine? – W. van Kuipers Mar 25 '16 at 6:24
  • 1
    @W.vanKuipers I did not have any other touch devices attached, just the magic mouse (bluetooth) though. Not sure if you meant a mouse with a real cord though. Anyway, It seemed that the reason in my case was a different one: FileVault caused the problem. After disabling it, the keychain works again. I mentioned it in my other question here: apple.stackexchange.com/questions/231340/… – Mathias Conradt Mar 25 '16 at 7:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .