2

I just installed Windows 10 on my MacBook (Early 2015, OSX El Capitan 10.11.2), and after everything set up I tried to plug in my External Hard Drive. I made sure this HD would and does work in Windows 10 by plugging it into another laptop I have running only Windows 10, and it worked fine there.

When I plug it into my MacBook with Windows 10 running, it:

  • Shows the notification asking what I want to do with the HD, I close it.
  • Doesn't show a Windows Explorer popup appears with the contents of the HD.

After this I go to Windows Explorer manually and try to open it. 2 things happen with this.

  1. I notice the drive is called "Local Drive" instead of its actual name, "My Passport" (named that because the drive is WD My Passport).
  2. When I go to open the HD, it gives me an error I have never seen before, Invalid Parameters.

When I first saw this I safely ejected the HD, and I got the BSOD with an error of KERNEL_SECURITY_CHECK_FAILURE. I guessed it was a problem with the safe eject feature, so I rebooted and ejected it without the safe eject function, and it gave me the same BSOD error.

Before anyone marks this as "off-topic", this is about Apple's drivers in Windows, not Windows itself, as the causes of the BSOD error suggest. None of the Windows updates seem to fix it, and I seem to be unable to find any driver fixes from apple.

Update: I can no longer even plug the HD into the computer, because when I plug it in it plays the little "Device Connected" chime, then the computer gives me the BSOD withe the same error.

  • Which Macbook & OS? – Tetsujin Jan 4 '16 at 16:19
  • MacBook (early 2015), OSX El Capitan (10.11.2), Windows 10 – Jaketr00 Jan 4 '16 at 16:22
  • Make sure to have your USB formatted as FAT, and also, I have had issues with some hidden files generated by OS X like .fsevented. You can remove these by rm -rf /Volumes/VolName/.fsevented. Also delete Spotlight_V100. You can prevent its creation with touch /Volumes/VolName/.metadata_never_index. Make sure to replace VolName with the name of your mounted volume – TheBro21 Jan 4 '16 at 19:06
  • @TheBro21 as I mentioned above, this HD works on another laptop running Windows 10. I have it formatted as exFAT, and sadly deleting those folders did nothing. – Jaketr00 Jan 4 '16 at 20:43
  • Does it work in the Mac install? – Flare Cat Jan 4 '16 at 21:06
0

I managed to finally fix this. All I did was reformat the External HD as the "MS-DOS(FAT)" filesystem through Disk Utility.

I'm assuming it was an issue with the "ExFAT" filesystem, although I could plug it into 2 other Windows laptops in my house with ExFAT.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .