2

I have set the Apple Mail "Archive" folder to something custom in the past with the help of this question. However, the folder that I was previously using is "stuck" as the Archive folder, and my efforts to set them to a new year (I use Archive/{year}) make no difference.

In El Capitan (10.11) it seems that they've changed how settings are stored so my changes to the ~/Library/Mail/V2/MailData/Accounts.plist appear to be being ignored. I've had a good dig around the new(?) ~/Library/Mail/V3/ and resulting ~/Library/Mail/V2/MailData/ folders, to no avail.

Unfortunately I'm poking around blindly, so I hoped that somebody here might help.

4

Under OS X El Capitan (tested with Mail 9.2), you can set it directly within the Mail application:

  1. Select your new archive folder.
  2. From the menu, choose Mailbox > Use This Mailbox As > Archive Mailbox

In German, it is Postfach > Dieses Postfach verwenden als > Postfach "Archiv".

Edit: Apparently at Apple they realized, that the menu location in El Capitan wasn't ideal and so they changed it again.

Under macOS Sierra (tested with Mail 10.1), you can still set it directly within the Mail application:

  1. From the menu, choose Mail > Preferences > Accounts > Select your account on the left > Mailbox Behavior

In German, it is Mail > Einstellungen > Accounts > Links den betreffenden Account auswählen > Postfach-Verhalten.

  • legend! works perfectly – Simon Stevens Jan 11 '16 at 10:45
  • Unfortunately, in Mail 11.3, I don't see any option to set the Archive folder under the Mail > Preferences > ... > Mailbox Behavior settings. My email account is an Exchange one, maybe the problem comes from that. – Michaël Polla May 15 '18 at 12:39
  • 2
    @MichaëlPolla, you are right, it is because of the Exchange account. It still works with IMAP but the settings do not appear for Exchange accounts. – Thomas Jochmann May 16 '18 at 13:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .