I just bought a new Seagate hard drive for Time Machine backups. I plugged it into my iMac and the hard drive never showed up in Finder. The drive does not appear in Disk Utility and the command diskutil list outputs only my system HD /dev/disk0. Even when I go to the System Profiler the drive does not appear under USB.

However, when I plug the device into a MacBook the drive shows up and runs regularly. I have made sure that the USB drive that I am plugging the hard drive into is working. I even formatted the drive using the Disk Utility on the MacBook put the drive still doesn't work on the iMac.

I think it might be a mounting issue but don't know where to go from here. How to make my iMac recognize my USB external hard drive?

  • 1
    Have you tried a different USB port on the iMac? Aug 17, 2011 at 1:07
  • 1
    System Profiler will show that the bus at least detects the other end of the driver board under the USB section. If you don't see any device when plugging in the drive and refreshing the window - you'll need to isolate the issue with a different cord and a different computer (assuming you can verify the port works on the mac with another device). Even an underpowered drive will show up as something connected in the profiler report.
    – bmike
    Aug 17, 2011 at 3:52
  • Is the drive spinning up? (i.e. does it make noise?)
    – Agos
    May 23, 2012 at 15:54

4 Answers 4


If your USB hard drive is the bus-powered variety (that is, you don't plug it into the wall for power), then it is possible that it is requiring too much startup current to run on one of your computers.

Some computers are pickier than others about how much current a device can draw, and over what period.

You might try a cable like this:

USB cable with power

Basically, you can use power from two USB ports, instead of just one.

If your hard drive has a jack for a power adapter, use that instead.

  • I've +1'd you, but if it's in an iMac, it's on AC, which means it should be drawing enough power (unless it's plugged into the keyboard).
    – user479
    Aug 17, 2011 at 5:19
  • @Randolph, I don't follow... What leads you to believe that this drive is not bus-powered? He didn't specify the external drive he is using.
    – Brad
    Aug 17, 2011 at 13:24
  • @Brad the drive has its own power supply Aug 17, 2011 at 16:52
  • Actually even though it's powered by the local wall current, most computers limit USB ports to around half an amp or so
    – Alexander
    Mar 7, 2012 at 0:08
  • @XAleXOwnZX, Yes, by standard the USB ports are limited to 500mW at 5V. But if the device isn't using it, it doesn't matter. What are you trying to say?
    – Brad
    Mar 7, 2012 at 0:43

If your drive does not show up in Disk Utility then it should not be the 'mounting' issue but more likely some in lower level. You need to plug some other USB device to test if your USB ports actually work or not.

  • The port works I plugged a usb mouse into it and it worked fine Aug 17, 2011 at 16:51
  • I had to mount my new Toshiba USB drive. For some reason Mac and Windows didn't auto mount it. Jun 14, 2015 at 3:35

I hate to post a solution like this but I replaced the drive with a new one from the store and it works. It was a hardware problem with the drive.


I have the same problem and I am using a Western Digital 1TB Passport. Every few days the time machine stops working and is not accessible. The only way i can get it to work is to go into System iformation>>USB and then highlight the My Passport and then for some reason the time machine logo on the taskbar becomes whole instead of having an exclamation mark in the centre and i am then able to run a backup

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .