1

I keep getting this dialogue on a recently upgraded MacBook running El Capitan -- it doesn't matter how many times I enter my password, it just keeps opening and opening:

enter image description here

This is appearing when trying to launch the Private Internet Access VPN client.

I've contacted their support numerous times and they just keep saying "ask Apple for help" (great..), but Apple has been unresponsive as well. I've been told it may have something to do with either

1) corrupt disk permissions ( which I've repaired, did not help) 2) corrupt keychain ( I rebuilt my keychain, did not help) 3) corrupt admin permissions (wasn't entirely sure how to repair this one..)

If ANYONE knows how I can get this stupid dialogue to go away so I can connect to my VPN client it would be much appreciated!

On a previous OSX install I had the client working fine (in Yosemite). When I did a fresh install for El Capitan, I tried to install it via HomeBrew, but that is when it stopped working. I've since uninstalled it from HomeBrew and tried to install via the website package, but I just get this error over and over and over. No matter how many times I enter the password.

EDIT additional information:

The client installs / runs fine if I create a fresh user account and install it there. This will not work for me -- I need it to run on my main (admin / primary) account.

I've tried installing the client both via Homebrew (Cask package manager), as well as through the download link from the PIA website. Both have the same issue.

I believe the issue began when I attempted to install through Homebrew -- I had had it installed the "normal" way in the past and it worked fine. Uninstalled the app. Went to reinstall it a few months later, this time through Cask, and then the issue started.

EDIT 2:

Here are the contents of my PATH.

My user account (the one that needs fixing):

/Users/Tom/.rvm/gems/ruby-2.0.0-p645/bin:/Users/Tom/.rvm/gems/ruby-2.0.0-p645@global/bin:/Users/Tom/.rvm/rubies/ruby-2.0.0-p645/bin:/usr/local/bin:/usr/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/Users/Tom/.rvm/bin

A "fresh" user account:

/usr/local/bin:/usr/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin
  • Have you tried installing something like LittlSnitch obdev.at/products/littlesnitch/index.html to get more information about what’s going on? You can download the demo version, and it will probably run long enough for you to get the info you need to help pinpoint the issue better. – kenjikato Jan 12 '16 at 1:54
  • hi @kenjikato , I'm downloading it now to give it a shot, thanks for the suggestion. What relevant info should I be looking for? – Prefix Jan 12 '16 at 3:48
  • before the message box you are already getting pops up on screen from the Mac OS, you should get a dialog box from LittleSnitch that will give you more info about what kind of request the system is making, to what address, and whether you should allow it or not. If you hit the ? icon in lower right you will get some more info about the request. Add this info to your question to help clarify it, and help others troubleshoot what might be going on. IF YOU DON’T get a LittleSnitch popup box, then the system is doing something else BEFORE it’s trying to access your network interface. – kenjikato Jan 12 '16 at 4:37
  • I don't get the LittleSnitch popup for the VPN client (it came up for all my other apps, steam/spotify/etc. etc.) – Prefix Jan 12 '16 at 5:09
  • That tells you that the VPN software is trying to change or validate something on your system BEFORE it it’s even trying to hit the network. Sounds like there is a deeper permission issue, or something isn’t configured properly then, especially given the data you added to the end of your question. – kenjikato Jan 12 '16 at 5:17
3
+100

I tried to replicate your environment in a OS X 10.11 VM (including homebrew/cask and rvm). After some trying I have been able to reproduce the error at times.

In my opinion the error is related with wrong permissions in your user folder, a really crappy app (the private-internet-access app) and probably your ruby/rvm environment.

The error you get is (probably) related with SCHelper and nehelper which can't fulfill their tasks successfully.

File Created: /Library/Preferences/SystemConfiguration/preferences.plist-new Modifying Program: SCHelper Process ID: 773 Process Owner: System Admin User ID: 0 Time recorded: 22:21:04, Sat. Jan. 16, 2016
...
File Renamed: /Library/Preferences/com.apple.networkextension.plist Modifying Program: nehelper Process ID: 183 Process Owner: System Admin User ID: 0 Time recorded: 22:21:04, Sat. Jan. 16, 2016
...
File ownership changed: /Library/Preferences/com.apple.networkextension.plist Modifying Program: nehelper Process ID: 183 Process Owner: System Admin User ID: 0 Time recorded: 22:21:04, Sat. Jan. 16, 2016

Please try the following:

  1. Rename your bash config files:

    cd ~/
    mv .bash_profile temp.bash_profile
    mv .profile temp.profile
    mv .bashrc temp.bashrc
    
  2. Remove all traces of private-internet-access in homebrew:

    brew cask uninstall private-internet-access
    brew cask uninstall --force private-internet-access
    brew cask cleanup
    brew cask doctor
    brew doctor
    
  3. Enable your root user, log-out your current user and login as root

  4. Remove the following files and folders:

    • /Applications/Private Internet Access.app
    • /Users/your_user/.pia_manager (folder)
    • /Users/your_user/.pia_manager_crash.log
    • /Users/your_user/Library/Private Internet Access (folder)
    • /Users/your_user/Library/LaunchAgents (folder)

    I tried to remove all these files and folders with sudo rm ... which wasn't successful. Some files were recreated immediately even after stopping/unloading the respective plist with launchctl. Therefore I used root.

  5. log-out as root, reboot, login as your main user and disable your root user.
  6. Recreate your LaunchAgents folder:

    mkdir ~/Library/LaunchAgents
    
  7. Download, reinstall, setup and test Private Internet Access
  8. Rename your bash config files:

    cd ~/
    mv temp.bash_profile .bash_profile
    mv temp.profile .profile
    mv temp.bashrc .bashrc
    

I recommend the following:

Follow the instructions and install and use Tunnelblick (instead of installing Private Internet Access).

  • you, sir, are awesome! This did the trick perfectly for me. I believe the specific thing that fixed it was disabling my bash settings (.profile, .bashrc, .bash_profile), installing the app (not through Brew) and then re-enabling my profile settings. Everything seems to work great now! I may take your advice and just use an alternative client as well to avoid headaches in the future. Thank you so much for your help! – Prefix Jan 18 '16 at 18:05
2

Here’s my suggestion to fix the problem based on the data you’ve supplied thus far, and that you’ve already tried the basic things.

  1. Uninstall the Private Internet Access VPN client. NOTE! If they don’t offer an uninstaller, DON’T just throw the app away. This will leave hanging bits that might be part of the problem. Use a tool like MacCleaner, CleanMyMac, App Cleaner, or App Removal.

  2. Uninstall Homebrew. I’ve seen cases where Homebrew has left stuff in a bad state if the installation didn’t go right the first time. Simply uninstalling the app didn’t fix the problem for me, I had to get rid of Homebrew as well.

  3. Run Disk First Aid and repair your Disk Permissions (sounds like you already know how to do this).

  4. Now’s the tricky part, you need to check your Keychain for leftover bits. So first run Key Chain First Aid, just to make sure your Keychain is OK.

  5. Next you need to search through your Keychain to see if you can find any keys, certs or passwords leftover from the VPN software you have been trying to run. So search on the name of the software, the IP or name of the server you are trying to access, or anything else you think is associated with the software. You will want to delete those keys, certs or passwords. BE CARFUL THAT YOU DELETE ITEMS YOU KNOW ARE ASSOCIATED WITH THE VPN SOFTWARE. Otherwise you might create more problems for yourself.

    Search Keychain for leftovers

  6. Reboot your computer.

  7. Re-download and reinstall the PIA VPN Software.

  8. Reconfigure the software and try connecting again.

Hopefully at this point your system will be free of any previous issues, and the new install will get things working again. If the problem STILL persists the only other suggestion I would have would be to rest your keychain. But I don’t recommend this unless all else fails.

  • Hey there. Thanks for the tips. I will try all these except I cannot uninstall Homebrew as I rely on my homebrew configuration for work (I'm a developer).. Shame of Homebrew is the root of the issue as I've never run into any issues using Homebrew/Cask for all my other software. – Prefix Jan 12 '16 at 16:15
1

I encountered this exact issue on my second try at upgrading to El Capitan. On booting up, I encountered the "network setup is trying to modify the system network configuration” dialogue that would not go away. For this second attempt, I had created and used a separate USB boot install drive rather than install directly from from the internet.

(After my first attempt via the internet, El Capitan installed without problem, but hung when the startup reached 100%. I suspect that the system was hanging before getting to the point of displaying the 'network setup' Username/Password message. I then reinstalled my Yosemite system from a backup.)

When the 'network setup' Username/Password message noted by the questioner appeared, the two answers given here gave me the clue that I needed --- PIA was the likely culprit, so that I needed to remove PIA from the upgraded drive before booting up.

My solution was then to boot from an external boot drive, then adapting to my situation the instructions for for uninstalling PIA that can be found at: https://support.privateinternetaccess.com/Knowledgebase/Article/View/52

i.e.,

  1. Move the file "Private Internet Access.app" from the Applications folder into the Trash, then empty the trash.
  2. Open Terminal from your Applications -> Utilities menu.
  3. Type the following command, hitting Enter afterwards:

    rm -rf ~/.pia_manager/

For booting from a separate drive, the '~' needs to be replaced by the path to that drive. Also, precede the command by 'sudo'. Take care not to accidentally hit 'Enter' before typing '.pia_manager/' !! Possibly a boot into Safe Mode could have been used to achieve the same end.

I have drawn this issue to the attention of PIA.

  • Thanks for the input! I also raised the issue with PIA but received no helpful input. Wishing you better luck! – Prefix Jul 9 '16 at 23:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .