I configured my Google account on El Capitan (OS X 10.11.2) using Internet Accounts and it worked fine for a while. However, after a restart the system asked again for the password and 2-factor authentication code, which I provided, but then I get stuck in the following window after entering my password and code:

problem authenticating with google

In the above window, if I hit Cancel and then try to select anything in the Google account I get the message "Unable to verify account name or password."

If I delete the account and add it again I'm asked for my password and 2-factor authentication code, but after providing them I get stuck in the following window - notice that the Done button turned grey after pressing it, and the dialog never closed after that:

problem authenticating with google

I already tried starting my system in safe mode, with the same results. What's happening? Any help will be greatly appreciated!

  • 1
    I am also getting this in OS X 10.12.3 (Sierra). Very annoying! – f01 Feb 10 '17 at 6:14
  1. Open Keychain Access.
  2. Make sure "login" is selected in the upper left under "Keychains" and manually delete every entry that is associated with Google (any entry with Google in the name, I deleted). Specifically, the entry "com.apple.account.Google.oauth-token" is the one to delete.
  3. Go back to Internet Accounts and add your Google account.
| improve this answer | |
  • 1
    For some reason this does not work for me in OS X 10.12.3 (Sierra) – f01 Feb 10 '17 at 4:33
  • Doing this plus google.com/accounts/UnlockCaptcha let me in again on macOS Sierra. – Sarah Vessels Feb 10 '17 at 16:04
  • 1
    This does not work for me in Sierra. It did, though, completely remove all my Google accounts, so now even if they fix the problem, I have to remember what I was using for what. – John Smith Feb 15 '17 at 7:34

This just randomly started happening to me on Sierra (macOS 10.12.3).

I removed my Google account from Internet Accounts in macOS so I could re-add it again. It brought up the login process and then hung at the end with no spinning wheel.

However, upon enabling "Access for less secure apps" in my Google preferences, everything started working again.

| improve this answer | |
  • Can you add your answer to apple.stackexchange.com/questions/272467/… as well? – nohillside Feb 10 '17 at 15:12
  • This didn't work in my case because I'm not able to enable that 'access for less secure apps' for my account since I have 2-factor auth enabled. "This setting is not available for accounts with 2-Step Verification enabled. Such accounts require an application-specific password for less secure apps access." – Sarah Vessels Feb 10 '17 at 15:53
  • @SarahVessels yeah IIRC using the less secure apps method is Apple's way of circumventing the app specific passwords solution – developius Feb 10 '17 at 22:39

I've been struggling with this issue as well for a few days on OS X 0.11.4, before that it worked flawlessly. In my case I went to Keychains > Login > Passwords > Google and removed all the security tokens.

Now I can add Google accounts again.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .