I have an external Firewire volume with some filesystem problems. One problem is that Disk Warrior can't fix these errors because there is not enough space left on this volume (in fact, it is completely full - 0 bytes empty, which I suspect is the reason for the FS-problems). Another problem is that this disk gets mounted readonly by the OS, hence I can't delete any files on it to make it possible for Disk Warrior (or fsck) to fix the file system. I have tried the commands in this question but they only generate an error message:

% mount -u -w /Volumes/MyVol 
mount_hfs: error on mount(): error = -1.
mount_hfs: Invalid argument

I also tried mount_hfs with different options, but something like this

% mount_hfs -o update /dev/disk3s3 /Volumes/MyVol
mount_hfs: error on mount(): error = -1.
mount_hfs: Invalid argument

How do I force mount this volume in readwrite mode so I can try to delete some of the files on it?

And you don't have to tell me to backup and erase the volume.

Update: I just found the hfs.util command and run it like this

/System/Library/Filesystems/hfs.fs/Contents/Resources/hfs.util -M disk3s3 /Volumes/test writable

but it just responds with is "usage" page. On this usage page there is an example that looks like this:

/System/Library/Filesystems/hfs.fs/Contents/Resources/hfs.util -p disk0s2 fixed writable

Can't see any difference between that and my command..?


I managed to delete some files to free up space on the device by connecting it to my NAS, where it was mounted as writable. Doesn't really answer my question, however it solved my problem. Now I am gonna try to fix the file system.

| improve this answer | |
  • I'm having a pretty similar problem... can you describe the steps in your solution? – 2rs2ts Jan 3 '16 at 19:19
  • I just connected the drive to my NAS which allowed it to be mounted writable. I then used the NAS file browser UI to delete some files off it. – d-b Jan 3 '16 at 22:14
  • I looked up NAS and it sounded like you had some sort of machine that let you attach drives to it and then see them as network devices, so in other words, not something I could do. Thanks for responding. – 2rs2ts Jan 5 '16 at 18:27

I have to do the following from the command line to get a USB drive to mount read/write:

diskutil list
sudo diskutil unmount /dev/disk2s1 <- (put your volume/partition in here)
cd /Volumes
sudo mkdir <FOLDER_NAME>
sudo mount -w -t msdos /dev/disk2s1 /Volumes/<FOLDER_NAME>

This is with a FAT32 formatted USB stick. Not sure why, but my Mac will only mount these read only when they automount, only started happening recently. Reformatting does not resolve it, even formatting in a macOS native filesystem gives me the same issue. This is happening on multiple USB sticks after many reformats and reboots.

The problem is that I have to do that each time I remove the drive and want to plug it back in.

| improve this answer | |
  • This worked for me when my external 2TB APFS drive mysteriously went readonly. I used sudo mount -w -t apfs /dev/disk3s1 /Volumes/<FOLDER_NAME> and it mounted readwrite! Thanks! – Aphex May 9 at 21:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .