17

I'm using the music receiver bluetooth TP-Link HA100 and when doing streaming from Spotify or iTunes the audio has clicks in and out and skips like a scratched CD. Simply unusable. I'm on MacBookPro late-2011 El Capitan 10.11.2

This is a known issue, I already tried these unofficial solutions:

http://lifehacker.com/fix-your-bluetooth-audio-in-yosemite-with-this-terminal-1670380974

https://apple.stackexchange.com/a/179209/90762

https://discussions.apple.com/thread/7263274?start=0&tstart=0

but they don't work.

Note 1: the audio lags/skips seems to increase everytime I do something on Mac (that is, open an app, scrolling a page in Chrome, ...).

Note 2: no one of the above issues on iPhone and iPad

Note 3: while streaming from iPhone/iPad if I just enable bluetooth (not stream) on MBP the audio begins to lag!

It's a lot frustrating and I can't believe bluetooth con OSX is so much crappy and there's no bugfixes on the horizon! Someone can help me?

8

I tried all the listed solutions and nothing worked for me on MAC Sierra.

Just the:

sudo killall coreaudiod

worked for me but only for max 1 hour. Than I had to reenter which is quite annoying.

The bluetooth sound quality was dropping extremely especially while playing videos (high CPU and memory usage). It was unbearable.

What finally worked:

I activated the sound equalizer which I already had installed but never used: "boom2" (unfortunately not a free applications; may be there are other apps free which might work as well).

This software resides between the Audio source (in my case Video application) and the bluetooth processing unit of MAC Sierra.

Because the bluetooth part remains in this solution unchanged the problem can not be related to bluetooth buffers or frequency interference on the radio waves itself.

It is a problem of the operating system itself.

I hope this solution might help others as well but I can not assure that this works in your specific environment.

fregatte

  • Boom2 is well-known 'crapware' & is best left alone, well away from your Mac. – Tetsujin Mar 2 '17 at 12:01
  • This solution is great!!!!!! Thanks so much this was driving me crazy. sudo killall coreaudiod totally fixed my problem! Boom2 is great software if you need it!!! I've used it for years to be able to hear media on my macbook air that was too quiet. Unless you have something better, Tetsujin, I'm going to start using Boom2 for this. – Andrew Paul Simmons May 20 '17 at 13:24
6

I have found yet another unofficial solution! it worked for me and i hope the same to you. i believe the macbook utilizes bluetooth in the background for handoff and FaceTime. i believe it searches occasionally for data or cues that are sent from secondary devices or stays quietly paired with a device you may already have (causing gaps in bluetooth connectivity). i signed out of FaceTime (disabling it) and disabled handoff. i have an iphone, and it seemed to create some kind of bluetooth interference. try this and see if it doesnt help or solve the issue

  • Thanks for your response, I am having the same problem. Trying out your suggestion to disable handoff. Will report on the results – Nikolay Spassov Feb 14 '16 at 19:31
  • 1
    Didn't do the trick for me (MacBook Pro, 15-inch, Mid 2015). And for those looking, handoff can be disabled from System Preferences > General > Allow Handoff (...) – losttime Apr 5 '16 at 16:57
  • Disabling hand-off in my mid-2014 Macbook Pro 13" El Cap 10.11.4 seems to have worked. – n8tr Apr 28 '16 at 14:32
  • Didn't work for me either (MacBook Pro 15" macOS Sierra 10.12.1). – Nick Sweeting Nov 24 '16 at 4:22
3

wireless mouse interferes with bluetooth

  • just turn it off and use track pad while you play or use bluetooth – Joe Orosco Nov 20 '16 at 0:33
2

This happens to me on Sierra as well. Sometimes it looks like it happens on it's own, and it always happen after I get a phone call. The audio becomes choppy, my magic mouse is choppy as well, etc.

However, turning off bluetooth on my iPhone seems to be an immediate workaround fix.

  • What a terrible workaround, but disconnecting my headphones from my iPhone fixed this for me. I'm on macOS Sierra and I have Plantronics Backbeat Pro headphones. – bentsai Jun 5 '17 at 18:20
0

Sorry but my solution was to sell the TP-Link HA100 and buy an Airport Express. No problems anymore.

0

Restarting just worked for me, on Sierra. I don't even have an iPhone (have Android) and using a bluetooth headset.

0

Ok this worked for me. Switched on bluetooth headphones and iTunes music was skipping. Left the sound running, switched off bluetooth keyboard and mouse and music became ok. Switched keyboard and mouse back on and music was still fine. So I don't know whether it's a priority device issue or what but it worked for me :-)

0

I have a similar problem. My bluetooth headphone was working perfectly, but it started getting choppy somehow, and I did answer a phone call via FaceTime.

The stuttering only happens when the current application is Chrome or Safari. Restarting the browsers and/or disabling extensions or closing some of the tabs didn't fix the issue.

My workaround is to go to System Preferences -> Sound -> Input. As long System Preferences stays in that screen, it doesn't stutter anymore when I switch back to Chrome or Safari... But then my bluetooth magic pad gets a bit laggy, though it's tolerable...

  • Welcome to Ask Different. Please don't add comments in the Answer field as this is for answers to questions. If you have a different question, ask it by clicking on Ask Question. Once you have enough reputation you can also add a bounty to get more users interested in the question. You can also read how to ask a question to improve your chances on getting a good answer. – Monomeeth Jun 29 '17 at 1:23
0

Just spoke with Apple Support, they gave me a cure for Choppy Bluetooth Audio interference. I have a Bowers and Wilkins T7 and this worked for me.

  1. Power down your iMac.
  2. Unplug all connected items from the iMac.
  3. Unplug the power cord from the back of the iMac and wait 20 seconds.
  4. Replug all items to the iMac (USBs, etc.), and then the power plug.
  5. Hold down the PR keys.
  6. Power up your iMac, and continue holding down the keys.
  7. When you hear the startup chime 3 times, release the buttons.

Wait till everything powers back up, and hopefully that is your problem solved.

I hope this helps.

  • 1
    and for how many days did this work? I can reboot and is OK for a day – Mark Jul 12 '16 at 12:33
  • 3
    Looks like in this P & R & Alt instruction tambourine and rat tails are missing – Dan Key Nov 3 '16 at 21:27

You must log in to answer this question.

protected by Tetsujin Mar 2 '17 at 12:02

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .