1

For some reason I am suddenly unable to type upper case I's on my Apple keyboard. All the other keys work fine and the lower case I works fine too. if I engage capslock I can type capital I's but as soon as I press shift along with I nothing happens.

Specs: Mac OS X 10.7.5, Mac mini, MB110B/B Keyboard.

  • I tried rebooting in safe mode but the problem persists. – JulianJ Jan 1 '16 at 10:45
  • Try changing the keyboard nationality and see if it helps. Also, try a different keyboard if you have one in reach – TheBro21 Jan 1 '16 at 13:06
  • Double check system prefs/speech to make sure I has not been set as a shortcut to activate text to speech, etc. – Tom Gewecke Jan 1 '16 at 14:14
  • I've found a far inferior keyboard and it works. I'm still puzzled why the key does not work though. I have also checked speech shortcut and changed language but still the i does not work when shift is pressed. – JulianJ Jan 1 '16 at 14:23
  • Maybe a speck of dust is interfering with the amount of electrical current. Have you tried pressing both shift and "i" very hard? – Trellis Aug 8 '18 at 14:21

You must log in to answer this question.

Browse other questions tagged .