I just tried to open Spotify's Mac app through the OS X LaunchPad, and when I clicked on the icon, the Mac app icon remains stuck on my screen.

I've attached some screenshots to show you. I don't know how to get it down. No matter what I do to the screen, the icon is always stuck "on top" of it.

How do I make this go away? If you're curious, Spotify opened on the second attempt. The first attempt it just got stuck.

enter image description here

enter image description here

enter image description here

enter image description here

  • Did you restart?
    – IconDaemon
    Dec 30, 2015 at 23:05
  • 5
    I have a ton of things open for work, I was hoping to avoid that...
    – Dwebtron
    Dec 30, 2015 at 23:09
  • I think ending your session (log out) or restarting the computer as suggested, may actually be the solution here. If you have a myriad of items open for work as you say, what makes it so difficult to just save the work, close the applications and then move on? No offense, but this sounds trivial to me.
    – Phoenix
    Dec 31, 2015 at 9:34
  • 1
    As AntonTheGreat mentions in a reply on this page, if it's a launchpad icon, open launchpad and click and hold an icon as if you are going to move it. That fixes the issue.
    – Dan Brady
    May 3, 2017 at 8:12
  • Holding an icon as if I'm going to move it does not (no longer?) work as of at least 10.15.7.
    – ijoseph
    Dec 28, 2020 at 5:34

7 Answers 7


Turns out, I just had to reset the 'dock' process. I opened Terminal and typed

killall Dock

and pressed enter. The screen flashed for a second, and everything came back with my stuck icon gone.

If that fails, the issue may be with Finder (this is the case with the similar issue of Stacks categories "burned in" to your desktop background). Running

killall Finder

will address that.

  • 8
    Worked perfectly. Much better than having to reboot!
    – Jack Vial
    Jul 15, 2018 at 14:40
  • 4
    In case anyone misses answer further down: killall Finder works if this one doesn't.
    – Spoike
    Sep 14, 2018 at 7:46
  • 1
    Thank you so much. I've had so much downtime from this happening over and over.
    – ldmtwo
    Oct 10, 2019 at 22:06
  • Super helpful, this happens to me frequently,
    – Tom Walker
    Feb 10, 2020 at 15:25
  • this helps, as I see the Dock restarted by itself
    – vladkras
    Apr 8, 2020 at 8:47

The easiest fix is to just open the app drawer, holding any icon until the move motion occurs, then move any application; it seems to fix it everytime it happens for me.

  • 3
    or launchpad in this case! i bet it'll fix the issue anytime it happens! Jan 4, 2016 at 20:26
  • 1
    I wish you posted this a few hours sooner! I figured it out this morning and am going to write up the answer that I used now
    – Dwebtron
    Jan 4, 2016 at 21:01
  • 1
    Yes, this approach was easy! I simply did this: 1) Open LaunchPad, 2) Click and hold on any icon, to get them to wiggle (like on an iPhone).
    – Michael R
    Sep 3, 2016 at 18:45
  • Always works. It worked on Catalina and continues to work on Big Sur
    – LondonGuy
    Sep 23, 2021 at 12:26

What I do is pressing CTRL+OPTION+ESC then relaunch Finder app. Force Quit or Relaunch Finder.app Works for me.

  • 6
    killall Finder worked for me.
    – Oleg
    Mar 27, 2018 at 20:02
  • This worked for me on High Sierra.
    – tk421
    Jul 18, 2018 at 20:07

Same thing!!

Very simple solution: Just search look for the original icon in the launch pad and drag it!

Apparently this is a drag action that never completed.


The same thing happened to me with Firefox recently. The way I got the icon to go away was to delete all desktop spaces except one. Hope it works for you.

  • Interesting. I already have only 1 space. But, making a new one makes it disappear, then moving back to the original and it's still there.
    – Dwebtron
    Dec 31, 2015 at 22:03
  • Strange. I think I added and removed spaces a few times and then it suddenly went away for good.
    – Drai
    Dec 31, 2015 at 22:26
  • I tried that. Thanks for the suggestion, but I couldn't get it to go away. :/
    – Dwebtron
    Jan 4, 2016 at 21:01

I had a similar problem with an app that won't to go away and was in the top of every window.

I installed htop (brew install htop) and searched for a part of the app name (F3), which brings me another app inside the app's folder.

Just pressed F9 and killed it. (Press q to quit htop)

The executable was not listed on Activity monitor, so htop helped me to find and kill it.


Working solution for me:

start the application that stuck to screen in launchscreen.

  • Welcome to Ask Different! We're looking for answers that provide explanations as to why it answers the question as well as why it's the best answer. See How to Answer for info on what makes up a good answer. - From Review -
    – fsb
    Jun 27, 2016 at 13:45
  • This doesn't help. Also, the question by OP confirms this as well.
    – eis
    Feb 27, 2017 at 12:54
  • That doesn't work. Most importantly because the app is already running.
    – Martin
    Jan 8, 2020 at 8:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .