2

After upgrading to El Capitan, then working on installing Rails, my iTerm2 shell now opens with x >, instead of just >.

Can someone please explain why this is happening, and help me figure out how to return it to it's normal home?

enter image description here

1
  • When I type pwd, the x disappears immediately and I am in $HOME, which for me is /users/randytolentino. I would love for this question to be appropriated to the write SE forum - I'll look into having it moved. – techtolentino Dec 30 '15 at 17:03
2

You have shell integration installed and the last command executed failed:

Example:

enter image description here

DoesNotExist cmd does not exist, thus an error 127:

enter image description here

Command status

The mark on a command line will turn red if a command fails. You can right click the mark to view its return code.

Re: https://iterm2.com/shell_integration.html

6
  • Hi, thanks for the quick response. Considering that this behavior occurs when I launch a new session of iTerm2, how can I find out what the error/code was? Right clicking on the x does not give me the same menu as the image you posted above. It just opens up a typical menu with options like "New Menu", "New Tab", etc. – techtolentino Dec 30 '15 at 17:49
  • Not sure why right-clicking on the mark would not present the last cmd context menu... but in terms of last error I would look at the end of your .zshrc ... simple test, add a pwd $(HOME) at the very end, does the error mark go away on a new zsh? – SushiHangover Dec 30 '15 at 17:57
  • adding pwd $(HOME) gave me a command not found: HOME – techtolentino Dec 30 '15 at 21:42
  • sorry... fat-fingered... just pwd or cd $HOME, just some command that will produce an exit 0 result – SushiHangover Dec 30 '15 at 21:43
  • First of all, thanks for helping me out. pwd had no effect when I closed out iTerm2 and relaunched it. cd $HOME just basically outputted the home directory /users/randytolentino then on the next line, still getting x > – techtolentino Dec 30 '15 at 21:49
2

This has been figured out. There was a leftover RVM script in the .zlogin file that was causing this error, and when I imploded RVM (to use rbenv), I forgot to remove this script.

Thanks to @sushihangover for the willingness to help!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .