11

When I use the "Hey Siri" feature to enable an alarm it usually works. But recently I've encountered a problem. The conversation with Siri would go like this:

<me>   Hey Siri, wake me up at 7 20.
<Siri> Your, 7:20 alarm is on.
<Siri> (short pause)
<Siri> Sorry Jozef, there has been a problem setting up your alarm.

And indeed the alarm is not turned on for 7:20. It would work for other times, ex. 7:10 (regardless whether an alarm at desired date exists or not).

Is there any special case when Siri can not activate a specific alarm?

This is not a problem with Internet connection (I have one) or understanding of what I said (the text is interpreted correctly and Siri actually seems to have turned the alarm for a short moment).

  • 1
    I don't think the alarm was every turned on, I think Siri was trying to turn the alarm on. I think Siri just defaults to saying that, even if there is an error. – Flare Cat Jan 5 '16 at 13:20
  • Well yes. When I say it was turned on it is because siri shows the image of the alarm with the switch on the on position. – Jozef Legény Jan 5 '16 at 13:42
  • Oh, don't know what to tell you then. – Flare Cat Jan 5 '16 at 14:57
  • @JozefLegény have you try to restart or even restore the iPhone? – Mattia Feb 14 '16 at 3:30
  • 1
    Any chance you have an existing alarm for 7:20 am AND pm? – samh Feb 14 '16 at 3:30
1

Be explicit when you ask for an alarm:

Hey Siri, wake me up at 7:20am."

Also, what version of iOS are you using? There were some issues with alarms not waking people up in iOS 9.1. If you are running 9.1, update to the latest version, 9.2.1, and see if the issue persists.

  • The concept of AM and PM is irrelevant when using a 24-hour clock as the OP said they were in comments above. – tubedogg Aug 29 '16 at 0:56
-1

While I have never dealt with this problem, there are multiple different things you can do:

  • Reboot your iOS Device (Press and hold down the power and home button until the screen goes black and the Apple Logo appears)

  • Disable Siri, Reboot your iOS Device, then re-enable Siri. [Settings - General - Siri - Siri: On/Off]

  • Make sure your iOS Device is updated to the latest version, in case this bug was fixed in newer versions.

Hopefully these tips work out for you!

  • It was already mentioned in the comments that this was tried and didn't work. OP states the issue hasn't happened in a long time now. Please be sure to review the comments before posting an answer. - From Review - – fsb Aug 31 '16 at 13:30
-2

Personally, I would check you ios update is that most recent version. If it is then what I would do is set the alarm manually. To be quite honest, not trying to be rude, setting an alarm manually surely can't be an issue unless you are very lazy aha!!!

If it is a real problem contact apple and hopefully they'll be able to sort it out for you. Hopefully this is helpful even though it's general common sense

  • 1
    To be quite honest, the only helpful bit of your answer was the first sentence. – tubedogg Aug 29 '16 at 0:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .