3

I am trying to login to iTunes App Store or the Mac App store on my Mac but it gives me the error every time "There was an error connecting to Apple ID server". Till now I have :

I am on El Capitan 10.11.2 on a 2012 Mac Mini.

What I have not tried is Keychain first aid, which was ironically removed in this version of Mac OS. About the security content of OS X El Capitan 10.11.2, Security Update 2015-005 Yosemite, and Security Update 2015-008 M…

What should I do ?

Mac mini, OS X El Capitan (10.11.2)

Here is the log from Console: http://pastebin.com/raw/8FTiHQF6

  • Try rebooting all your network hardware, then the Mac. – Tetsujin Dec 30 '15 at 13:45
  • @Tetsujin I have done that already. All the other services on my Mac connect to the internet just fine. Everything that connects to Apple ID server does not. – uiwarrior Dec 30 '15 at 23:59
  • A problem I run into a bit to often when someone complains about something not working, IS IT CONNECTED TO THE NETWORK? – absenthecon May 22 '16 at 14:51
1

Old question: new answer. Today I had the same problem on my iPad mini. It turns out that a prior troubleshooting solution was to manually reset the date to an earlier time. My date was 4 years (yes!) off. I went to settings and changed to my iPad time to "set automatically" and everything worked. Other symptoms besides this included the search function in the app store never returning any results. That was also fixed once the correct time was set.

-1

Try going into Keychain and checking under Keychain Access --> Preferences --> Certificates to make sure both OCSP and CRL are "Best attempt". See discussion here:

https://discussions.apple.com/message/29988458#29988458

  • Please add the relevant parts of the linked page directly to your answer. Adding a reference is ok, but answers should stand on their own without having essential information hidden on another site. – nohillside May 22 '16 at 16:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .