I have a 2015 MacBook Pro running El Capitan with the new taptic force touch trackpad thing. Which, I must add, is fantastic!

However, this morning I started it up to discover it would not click/select anything. What is this madness? How do I fix it? How do I stop it happening again?

Things that work:

  • Typing with the keyboard.
  • Moving the mouse around.

Things that don't work:

  • Touch to click (I had enabled that setting)
  • Press to click (track pad makes a clicky sound but does nothing)
  • Deep press (track pad makes double clicky sound)
  • Two finger press (for right click)

Have Tried:

  • Restarting the Finder
  • Restarting my Mac
  • Making sure it is pugged in at the wall
  • Vigorously tapping the trackpad in frustration
  • Using expletive language

Unfortunately, I had no success with the above.

Previously, there were no issues with the trackpad. This mac is relatively new, I cannot think of any installed software that could be causing this issue. Any help much appreciated. Thanks.

  • Expletives seldom work, but I still keep trying too. – Nic Cottrell Jun 9 '19 at 12:56

My trackpad (MBP Early 2015) was working, but there was no haptic feedback, or any indication that force touch was working. Other functions (trackpad, single tap, scrolling, etc.) were working. Here's what my settings looked like: enter image description here

For me, it was fixed somehow by an SMC reset with the charger disconnected, while powered on. Basically, I pressed Control + Shift + Option + Power button. The system instantly shut down without warning. Force touch and haptic feedback were back when the system turned on.

Do I recommend this? No. It's an unclean shutdown. Did it work? Yes it did.

| improve this answer | |
  • 3
    After trying some of the other solutions, this is the one that finally worked for me. Thanks! – Krejko Oct 28 '17 at 22:16
  • Context: A restart didn't help. Booting to another OS didn't help. The usual stuff (SMC/PRAM resetS) didn't help. I discovered this accidentally when I was about to do yet another SMC reset, but forgot the fact that the Macbook was still on. I'm not sure whether the charger needs to be disconnected, but it makes sense. – user3247189 Apr 3 '19 at 15:17
  • This worked for me too. I had to hold (Control + Shift + Option + Power button) until it shut down. – Sam Brodkin Jun 4 '19 at 19:02
  • it magically worked :D even restarting machine didn't worked :D – w3debugger Jun 26 at 10:32

Got this this weekend, I was starting to go a little cranky when I saw my 2015 MBP wouldn't click. Tried restarting, to no avail.

At one point, I unchecked 'tap to click', big mistake because I couldn't click anymore, so I connected a USB mouse to regain tap-to-click, but still no trackpad clicking.

I came across this answer from user jbjose80 on Discussions.Apple, recommending instead of rebooting, to shut down and boot back up. Sounded silly, but worked like a charm. Phew!

(Originally posted on Retina MacBook Pro (non-Force touch) trackpad can't "click" as usual, but that was the wrong model)

| improve this answer | |
  • I can confirm that performing a shut down and then rebooting resolved the haptic feedback issue on a MacBook Pro 15" Retina Mid 2015 model. When the system is shut down and powered off, even momentarily, the vast majority of the system's peripheral components are also fully powered-off, so when the system is restarted, it starts up in a clean state (peripheral-wise at least). – bluebinary Nov 19 '17 at 5:00

Same problem, but the SMC reset (Control + Option + Shift + power button) fixed it.

| improve this answer | |

The issue was solved by connecting an external mouse via blue tooth and just clicking around the screen.

This mouse had previously been set up, so it only required turning on the mouse to connect. The MacBook's inbuilt TrackPad then started responding to clicks again and everything works as expected (presses, clicks, and deep clicks, etc).

The cause of this problem remains unknown, therefore I have no idea how to prevent it. Note: it has not happened again since.

| improve this answer | |
  • If you have a more complete answer or explanation please feel free to post it. I may have solved my issue but the question is still not fully answered. Have a fantastic day! – puqeko Dec 30 '15 at 7:04

I tried some of the methods suggested here but none of them worked. Then I realized there's a toggle button on the trackpad, I turned it on/off and that worked for me. Note: I have an external trackpad.

| improve this answer | |
  • This answer is simple and worked for me. Definitely recommend trying it first! – Alex White Nov 2 at 17:08

I had the exact same issue which happened without any warning or damage to the computer. I tried restarting manually and updating software; it did not work. However, I came across this website and the option of the control + shift + option + power button worked beautifully for me. Weirdly, I had to press the option button on the same side of the control button. If I tried to press it on the opposite side the computer would not shut down or restart. As soon as it rebooted with the hard reset, the trackpad haptic click was working again.

| improve this answer | |

I have just had this problem. I have a bluetooth trackpad that I occasionally use. It was under a pile of books and so was being pressed. It took me 45 minutes to figure out why my internal trackpad and an external mouse wouldn't click after I logged in (but did work before I logged in).

| improve this answer | |

Sadly with 3 years of dealing with this situation with all possible manual methods and recently I have had time to contact Apple Care. And then they conclude that is the fault of the hardware! The last thing that I can do now is to disable the Force Touch Trackpad apple that was first introduced on the Macbook Pro 2015. You will not see the error can not zoom, back page ... Lost Force touch feature (or force feedback), although it is still better than the previous MacBook Trackpad, but the above shows it is the biggest disappointment for the Macbook Pro 13 user community - the Force Track Trackpad 2015 in general!

| improve this answer | |

Same issue here but I resolved it with a PRAM reset.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .