20

There's an iMac whose FaceTime HD camera isn't displaying video images in applications like FaceTime, Photo Booth, or QuickTime video recorder.

OS X El Cap shows that the camera is attached and registered properly in the About This Mac - System Report.

  • fresh new install of El Cap on a Fusion drive. Previously the camera worked well with Yosemite.
  • the green light indicator flashes on/off repeatedly and irregularly when you start an application that uses the camera
  • there are no error messages or anything about no cameras being attached.
  • pressing the big button to take a photo in Photo Booth has no effect. The button is on the screen, but isn't pressable.
  • Skype is not installed

What steps can I take to get the camera to capture and display video properly?

enter image description here

Attempts to fix

Items to investigate

I recently opened this iMac to install an SSD. All cables were re-attached properly.

enter image description here

  • 1
    The green LED should stay solid when the camera is recording. Your troubleshooting clues: the LED flashes & you get no image, and that you recently cracked the case and played around inside, is an indication that either some of the cables were not attached correctly, not fully seated, or some other damage went down whilst the iMac was open. – IconDaemon Dec 29 '15 at 23:48
  • None of this worked for me. I also put in an sdd and made a Fusion drive. I also upgraded the RAM from 4 to 6 GB... The camera is working, and does go off when I quit the app that should use it. There is no missing camera message. Green light is constantly on. Photo boot remains dark, skype simply keeps looking for the camera, waiting for the picture to come on. – Bevis Stevens Feb 3 '17 at 19:22
  • Wait, what's this about Skype? I have it installed but it's not running (according to ps aux | grep -i skype). – Michael Dec 21 '17 at 23:09
39

I have had this problem in the past. I found my answer here. http://osxdaily.com/2013/12/27/fix-there-is-no-connected-camera-error-mac/

Open terminal from the utilities folder in the applications folder. Type sudo killall VDCAssistant into terminal and click enter. Then, enter sudo killall AppleCameraAssistant. That should do the trick.

  • 1
    My camera stops working. I google all over the place, and find various ideas of broken cables and faulty El Capitan upgrades. Then all of a sudden your answer comes up, not voted up even once. I follow the two steps. And the camera works. Thank you. – Paolo Jul 5 '16 at 14:27
  • @Paolo you're welcome! :) I was googling everywhere too. I guess I got lucky with the article I found. – JBWar Jul 5 '16 at 18:34
  • 2
    $ sudo killall AppleCameraAssistant No matching processes were found.! Any idea why – Kunal Panchal Aug 28 '16 at 7:21
  • @KunalPanchal hmm... my first suggestion would be to copy and paste directly into terminal (in case of a misspelling) but that probably won't fix it. Next, I would check activity monitor for the process and try quitting it from there. If that doesn't work, reboot and try everything again. Hope this helps! – JBWar Aug 28 '16 at 12:02
  • @cavalcade no problem! – JBWar May 27 '17 at 1:56
3

Resetting the SMC solved the camera issue. It's now working as per normal.

All that involves is shutting down the machine, removing all power from the computer for 15 seconds, and restoring power.

1

I was having this problem with my Mac - the screen was completely black when trying to use the camera for Skype etc. Simply rebooting and unplugging my computer, closing all apps, empty the cache, fixed the problem instantly!

-2

sudo killall AppleCameraAssistant

  • 2
    Providing more than a command would be useful. FWIW, some askers might not know where to input the command. – Bora Nov 23 '16 at 4:50
-2

works for me after i remove icloud drive.enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .