3

I want to edit Finder Info.plist file that is located here:

/System/Library/CoreServices/Finder.app/Contents/Info.plist

But when I try to edit the file by vi the file is readonly.

# vi /System/Library/CoreServices/Finder.app/Contents/Info.plist

When I try to chmod or chown the file nothing happens.

When I try to change file permission from Finder I get the error: "The operation can’t be completed because you don’t have the necessary permission."

The Locked checkbox in Get Info is disabled.

I also tried:

sudo chflags nouchg Info.plist

But after all that, file is still readonly.

What is preventing root from editing this file on OS X El Capitan 10.11.2?

4

That file is explicitly protected by SIP.

ls -lO /System/Library/CoreServices/Finder.app/Contents/Info.plist

The "restricted" flag listed by the O (capital letter o) option to the ls command shows SIP status of the file.

To change that one file, you would need to disable System Integrity Protection. SIP is a security measure to prevent any User up to and including root (and thereby most malware) from modifying system files.

To disable:

  • Boot into Recovery Mode (Hold Command+R while turning on Mac).
  • Open Terminal (Click Utilities > Terminal).
  • Type: csrutil disable
  • Restart your computer, and SIP will be disabled.

You should now be able to modify Finder's info.plist file.

  • thanks it worked but i booted into recovery by holding Command+R – Seifolahi Dec 29 '15 at 18:05
  • @Seifolahi, Yes, per OS X: About OS X Recovery it's "command ⌘ + R", and the answer has been edited to reflect that. – user3439894 Dec 29 '15 at 18:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .