5

I'm not able to use my SD card on my MacBook Pro after I upgraded the OS to El Capitan. I tried to reset PRAM without success. Consider that if I put the SD card on another Mac it works perfectly. Any suggestions?

  • 1
    Does a different SD card work with your MacBook Pro? – grg Dec 29 '15 at 15:33
  • I have only this one available :( – Boh Dec 29 '15 at 15:37
  • Does diskutil list show the SD card when attached? What format is the SD card? – grg Dec 29 '15 at 15:37
  • Nope. Format is microsd inserted in a SD Adaptor – Boh Dec 29 '15 at 15:46
  • Interesting, so it's not being read at all, rather than just not being shown in Finder. By my second question, I meant disk format (HFS+, FAT32, etc). – grg Dec 29 '15 at 15:48
4

I would install the older OS to another USB drive so that you can verify that the new OS is really causing the issue and it's not a hardware failure.

When you boot to the old OS (hold option key when booting to choose which OS of the ones connected) run diskutil list to check the filesystem on the SD card.

It's unlikely that it's a format that's no longer included in the new OS. It's more likely that you'll find the card itself faulty or the hardware has changed and needs to be cleaned (lint can obscure one pin connector) or repaired. You can also get a USB to SD card reader to avoid needing to reinstall the old OS just to eliminate the SD card reader as a potential source of the problems on the Mac with the new OS.

1

Remove the SD card, reboot the machine and don't put in the SD card until it is completely rebooted. Worked for me.

  • OMG, I thought a simple reboot would NOT work since the SD card worked in my MacBook Pro. But that did the trick for me too! I was pretty p'd off because it's brand new and I didn't think to try it out before I off the continent to Egypt! Phew! – user197115 Aug 13 '16 at 19:35
1

I've just encountered the same issue, and after some research found that the problem is that OS X does not load the SD kext (Kernel Extension - a driver) for whatever reason. Loading it manually resolves the issue.

  1. Eject the SD card
  2. Open Terminal
  3. cd /System/Library/Extensions
  4. sudo kextload AppleSDXC.kext (enter your password for sudo access)
  5. Insert SD card

After this, my SD card appeared in diskutil list and in the GUI Disk Utility and was mounted in Finder. Annoyingly this has to be repeated after rebooting, or you can automate it.

0

I was able to fix this by doing the following:
starting my mac in recovery mode by holding cmd + opt + r
selecting disk utility
clicking mount for my SSD
clicking first aid
restart my mac

  • Please don't post the same answer for random questions – Greenonline May 19 at 0:30
  • my solution fixes all of these problems. a bad HD is the root cause of all of the issues i commented on. – incognito nerd May 19 at 8:22
  • Can you elaborate on how manually mounting the internal SSD fixes issues with an external SD card? – nohillside May 19 at 13:18
  • its a hardware issue with the internal drive. first aid doesnt erase ur internal drive. it repairs it. the drive isnt mounted when you run ur mac in internet recovery mode so u need to mount it in order to click first aid. – incognito nerd May 21 at 3:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .