Disk Utility

I can't make my main Macintosh HD partition bigger. It's limited by the FAT partition in the middle, which seems to be frozen, I can't move it down to make space for my main partition.

To get some background, I originally had those 2 partitions sharing the space in peace. Then, I created a 3rd partition to experiment with another OS. Once done I deleted that new partition, and boom. It became a no-man's land that neither partition can claim.

I just want to have things back the way there were :(

  • Also, I tried using the Recovery tools, same thing
    – nute
    Aug 16 '11 at 17:15

It appears you have space to image the entire DISK0S4 partition to a compressed img file that would be stored on Macintosh HD.

From there you will be free to delete the partition, upsize Macintosh HD on the fly, and then make a new DISK0S4 FAT.

To start, just select the DISK0S4 and then go to the menu:

  • New ▶ Disk Image from "DISK0S4"...

You'll want to mount and verify the image well before erasing anything. Also consider it will be at least twice as slow to move data from one part of the drive to another if you have a HDD with physical heads that have to move. Dumping that partition to an external drive is far faster - you can still use Disk Utility to compress the image to save space and time since the CPU can usually out compress any external disk at less that 25% usage - the bottleneck is the write speed of the drive.

  • Doing this all in recovery console might be a little faster or robust for the Macintosh HD resizing since no file could be in use, but most of the time, you can do this operation while booted from the Macintosh HD partition.
    – bmike
    Aug 16 '11 at 17:57
  • I'm saving the dmg image now... How do I re-import it as a partition after? By the way, this partition is a Bootcamp partition that is also used by Parallels.
    – nute
    Aug 16 '11 at 20:07
  • Since it's bootcamp, I might let the assistant re-make the partition when you're ready for that. In disk utility you click the restore button at the top of the window (you're showing the partition view now) and drag the DMG file into source and the new FAT into destination. You may have to scan the image before it will restore. It will tell you / force the scan if needed so don't worry if you get to skip that step.
    – bmike
    Aug 16 '11 at 20:16
  • I created the new FAT partition, then went to do the restore, but: Could not validate source - Device not configured
    – nute
    Aug 17 '11 at 9:07
  • I think my dmg image is corrupted, I can't even open it it says it can't find the filesystem or something... maaaaannn
    – nute
    Aug 17 '11 at 9:32

You have to actually delete the FAT partition at the bottom, you can't just drag it into oblivion. The instructions to do this are actually in the image that you uploaded.

enter image description here


After reading your comment, it appears that I misunderstood the intent of your question. Disk Utility can't dynamically resize/move FAT partitions. You're going to have to back up that data, delete the partition, create the layout that you want, and then restore the data.

  • uhh but I have stuff there, that's a real partition that I am using.
    – nute
    Aug 16 '11 at 17:44
  • @nute - Ah, I misread your question then. My fault.
    – MDMarra
    Aug 16 '11 at 17:44
  • The funny thing is, I never meant to resize or move the FAT (that sounds like I'm talking about liposuction). All I did is delete a partition that was sitting in between the 2, and FAT moved up by itself.
    – nute
    Aug 16 '11 at 20:11

When you deleted the 3rd part ion you didn't actually delete it, you merely removed the filesystem that was in it. You need to change the partition mapping scheme to be a 2 partition layout, which should then allow you to increase the size of partition 2 so it can use it. Then you have 2 partitions, and you can increase they size of the first, and decrease the size of the second at the same time, as it will now have enough space to "move" as it were. This will take ages.

Edit: Sorry, just realised that as above because it is FAT you cannot resize, it's a backup/remove/recreate/restore job for the bootcamp partition, sorry about that.

  • Those darn FAT / MBR restrictions! You'd think we could forget about them now that we're running Lion, but Noooooo - they keep haunting us like a bad decision and too much garlic.
    – bmike
    Aug 16 '11 at 18:54

I had accidentally removed my Windows 7 Bootcamp partition from Disk Utility (should have done so thru Bootcamp). It deleted the partition of ~80GB and made that "Free Space". I was restricted to change the size of my Macintosh HD to retake the ~80GB of free space and I searched all over the internet for a fix. There was nothing that helped my recover the "Free Space" partition.

However, I found this solution myself which worked instantly:

  1. Go to System Preferences
  2. Click on Security & Privacy
  3. Choose FileVault
  4. Decrypt your hard drive (this may take 1-4 hours, be patient)
  5. Restart your computer
  6. Go to Disk Utility and verify your both Macintosh HD and the partitions
  7. Assuming they are in good condition, click on "partition" and you should be able to resize and recoup the free space.

This worked for me.


Not sure this is applicable to your situation, but I somehow got mine resolved.

Story: I tried to manually install Windows 8.1 with bootcamp and it failed to auto install, so I manually partitioned some free space with disk utility. After I tried to install windows again the setup created this evil "disk0s4" partition that is protected with no user privilege to modify or remove.

Fix: I attempted many resolutions suggested on the web but none of them worked, then I thought to myself, if this partition was created by the MS windows installation boot disk would that be the place to remove it? So I ran the Windows setup procedures again (inserting the disk/bootable usb, and hold option when boot, then select "windows" or "windows setup" or however you name your installation source). When I reached the part where I can select which partition to install, I then delete the "disk0s4" partition from there. Restart your mac, launch disk utility again and its gone!


  1. Insert OS installation disk/USB (Windows 8.1 for me)
  2. Boot holding option and select the source (Windows on a USB for me)
  3. Proceed with installation till you hit the part with several partitions
  4. Select and delete the "disk0s4"
  5. Remove the installation medium and reboot
  6. Launch disk utility again and it should be gone!

Hopefully this helps!


Well what worked for me was to partition a third partition smaller than the original container disk 1 and then shorten the container disk 1 into oblivion and then Macintosh HD will fill up the space and much as possible wait for the process to increase and done!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .