4

Starting recently, my MacBook Pro running OS X 10.11.2 loses its Internet connection every five minutes or so.

My router, a Technicolor TC8717T (don't ask, it's the free one from my ISP) provides two wifi networks:

  • TC8717T88 (2.4 GHz)
  • TC8717T88-5G (5 GHz)

Regardless of which wifi network I'm connected to, the Internet connection will die after about five minutes. The computer will remain connected to the wifi network, at full signal strength, but I'll be unable to browse to any websites or do anything over the Internet.

When this happens, Network Diagnostics will report that the connection to my ISP is failing, and Wireless Diagnostics will report a "WAN Connectivity Failure" and advise that I restart my router.

At this point, if I do any of the following...

  • Switch to the other network (from 2.4 GHz to 5 GHz or vice versa)
  • Disconnect from and reconnect to the same network
  • Turn my wifi off and back on
  • Restart my router

...the Internet connection will be restored, but only for another five minutes or so, until it fails again in the same fashion.

What could be causing this, and is there anything else I can try?


Update: two other pieces of info that I've discovered:

  • When the connection drops, other devices on the same wifi network remain connected. For example, my Apple TV will continue to stream a show, even though the MacBook Pro has lost the connection
  • ...but at the same time, my MacBook Pro only exhibits this issue on my home wifi network. For example, on my office wifi, the connection is always stable

Here's a screenshot of my network settings:

Network Settings

  • This looks a lot like a traditionnal problem with the cursed Automatic location (which in fact is a network configuration). Could you include a screen capture of your System Preferences > Network? – dan Dec 29 '15 at 8:20
  • Please add: the make of your wireless router, and the names of your 2 wireless networks. – dan Dec 29 '15 at 8:22
  • @danielAzuelos, what's the problem with the Automatic location? That's how mine is set as you can see, but I don't know what the alternative is... – daGUY Dec 30 '15 at 21:36
  • Please check the idle timeout settings in your router – klanomath Dec 31 '15 at 2:07
  • 1
    @RafaelOliveira yes, replace the router! 😛 – daGUY Oct 1 '17 at 15:15
1

I suggest you to turn off the 2.4 GHz wireless network named TC8717T88 on your router. Then your Automatic location will stop magically switching from one to the other wireless networks, thus having the valid IP for the other network (which doesn't fit the DHCP lease of the actual one).

You will be able to change this from a perfectly connected computer (ideally through Ethernet). Open your web browser, and connect to your TC8717T router with:

http://192.168.0.1

login:          admin
password:       password

goto:

Gateway > Connection > WiFi

click:

EDIT

Configure as disabled the "Private WiFi Network Configuration (2.4 GHz)". Configure on Manual channel choice the "Private WiFi Network Configuration (5 Ghz)".

I made the hypothesis (which is quite often the case) that your 2.4 GHz is overloaded and sometimes subject to access failure due to interfering neighbours network. Then by forcing your connexion on 5 GHz and a given channel you will get a stable one, without anymore dynamic IP renewal.

  • Switching between different frequencies (or channels) shouldn't affect neither DHCP nor the validity of the IP! IEEE 802.11 is OSI 1/2! Switching between 2.4 and 5 GHz using my router is almost seamless: maybe some IP packets get lost; but they will be retransmitted. – klanomath Dec 31 '15 at 2:02
  • Because (if I guess right) you defined these 2 channels use as one network on your router, with one name and hidden one DHCP range of IP addresses. – dan Dec 31 '15 at 7:14
  • I don't think this is it, because I have the same problem when I'm connected to the 5 GHz network too. It's not switching back and forth between the 2.4 GHz and the 5 GHz, it's just failing after a few minutes on either one. They're set up as two different networks with two different names, as I mentioned in my question. – daGUY Jan 10 '16 at 22:32
  • To try to understand your problem, is it working fine with only the 5GHz network? – dan Jan 10 '16 at 23:26
  • No, it's not – I disabled the 2.4 GHz network and I still have the same problem on the 5 GHz network (had to disconnect and reconnect to post this very comment). – daGUY Jan 11 '16 at 6:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .