0

I'm using the following audio interfaces:

  • Internal audio
  • Thunderbolt Display audio
  • RME Fireface UC (USB audio interface)
  • Alesis ControlHub (USB audio interface)
  • Orion32 (USB audio interface, used occasionally at a friend's studio)

Everything was working fine on Yosemite. I upgraded to 10.11.2 a couple of weeks ago and since then, I've been experiencing the following:

  • When connected to the Thunderbolt display, it doesn't appear in the audio device list. Instead, the Orion32 device appears. I checked to see whether there's just a title mixup with the display audio, but nothing comes out of the speakers when selected so that's probably not the case
  • The Alesis interface does not appear in the list and is unusable. According to this KB article, it should work out of the box. I also tried disabling SIP as detailed in this article (which deals, though, with another audio interface). I opened an issue at the Alesis support forum but don't have my hopes up for a reply from them, seeing other people complain about USB devices and getting no feedback.

I'm assuming that the two issues are related. I haven't tried connecting the real Orion32 device, as it's not in my studio, but the RME device works fine.

I would appreciate any input on how to investigate further.

1

So, for the sake of documenting this: I suspected that the Orion32 driver might be causing the trouble. Looking at system.log, every time I connected the Control Hub, the Orion driver logged some error messages. I deleted the driver and restarted the machine, which seems to have solved the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .