0

Currently I have an issue of changing input source on my iMac, OSX 10.11 The option in the Keyboard setting is: Select the previous input source control+Space. There is no other option available. What I want is Command+Space. (This hotkey was bind to Spotlight search. But I have already disabled it.

The other iMac I have runs the same OSX version but does not have such issue. Anyone could help?

1
  • Click the shortcut. It should become a text box with the shortcut highlighted. Press command+space. The new shortcut should be there. I won't post as an answer yet because I'm not on OS X 10.11. – Arc676 Dec 28 '15 at 7:12
0

System Prefs > Keyboard > Shortcuts > Input Sources > [√] Select next source in Input menu > [double click on far right side and press Cmd ⌘ Space. It should be as simple as that. If it's still not binding, check all the other shortcuts and make sure nothing else has been bound to it. If it still does not work, it might help to use an external application to unbind the key and rebind it. I use Spark 3personally because it's free and it works for the few rebinds I need.

0

Untick "Show Keyboard, Emoji and Symbols" in System Prefs > Keyboard > Keyboard. It seems that it uses Cmd+Space in some way (in the Edit menu in the menubar you see that "Emoji & Symbols" uses Ctrl+Cmd+Space).

3
  • Did you really find it necessary to do this just to change the input menu shortcut from control plus space to command plus space? The OP's problem was just not knowing how such changes are made in general. – Tom Gewecke Jan 26 '16 at 13:03
  • @TomGewecke Actually yes, before I unchecked the "Emoji & Symbols" box, nothing happened when I pressed Cmd+Space even though I had defined it as the shortcut to switch input methods. It is true that OP does not mention this, though, I suppose I misread the question due to my own issue (but I'd be curious to know if it also happens on other people's systems). – user167209 Jan 26 '16 at 13:10
  • Interesting, thanks! I was able to change mine back and forth without unchecking the emoji/symbols box. – Tom Gewecke Jan 26 '16 at 13:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .