2

I've got an Early 2015 MacBook Pro (128GB, MacbookPro12,1) and I'd like to run Windows 10 on it but as its own OS instead of via a virtualisation program. Due to the space constraints imposed by the 128GB flash drive, I've installed Windows 10 (using Rufus) as a Windows To Go installation on a 32GB Sandisk USB 3.0 stick I've got.

Windows 10 works perfectly normally from the stick (I boot into it via EFI) but I can't get the drivers for the hardware from Boot Camp. Whenever I run BootCamp on my Mac, it tells me I don't have the 50GB free on my boot disk that I need to be able to partition (I don't), but it won't go any further and give me the option to download only the drivers.

The only thing I want from Boot Camp Assistant are the drivers for Windows 10.

Is there a way to fix this? The Boot Camp 6 drivers (needed for Windows 10, apparently) don't appear to be anywhere online - I could only find version 5 on Apple's website, which I believe is only designed for Windows 8 (the setup program doesn't work on my MacBook when running Windows 10, anyway).

Any help is much appreciated, I'm rather noobish with all this stuff!

Cheers, Dan

2

I'm on a Mid 2012 Macbook Pro w/ Retina and El Capitan 10.11.2.

I was able to do boot camp assistant > download drivers (no other options selected) Bootcamp would ask for a usb drive, ignore it and close the pop up. From here I took my mouse up to the menu bar, and did Action > Download Windows Support Software.

The first time I tried this I got the error "The Windows support software could not be saved to the selected drive. An error occured while saving the Windows support software".

The second time I tried it, a day later with a reboot, I tried it again and it worked. Not sure what made the difference. Finder might have not been running as I'm running a trial version of Path Finder.

  • ARGHHHHHH I was being impossibly dense, I didn't think to look at the menu bar. I feel a little bit silly now... – Dan Grove Dec 28 '15 at 14:57
  • It didn't work for me in the end, I'm quite perplexed as to why, the download goes on for a good while, maybe 20 - 25 minutes and then errors out as per my screenshot. I looked at the menu bar because I wasn't getting anywhere in the main window. Here's hoping it works for you though. I wonder about reproducibility. Keep us posted. – adamlogan Dec 28 '15 at 15:15
  • Mine worked fine first time, that's really strange – Dan Grove Dec 29 '15 at 11:53
  • I just tried it again today, and it worked. Weird. A reboot might have done the trick. I'm not sure. I am using Pathfinder as my file browser, Finder might have not been running or something. I did note that admin priveleges were required. Will update my post. – adamlogan Dec 31 '15 at 4:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .