0

I want to permanently change my keyboard layout. Every time I restart my computer, I have to add Spanish ISO layout and delete the US one.

My Macbook has a spanish keyboard but I use OSx in english.

1

You can rearrange the languages from System Preferences > Languages. Don't delete English but put Spanish ISO first. I've it like that and the config sticks through restarts and the like.

| improve this answer | |
  • 1
    The OQ is about the keyboard layout, not the language used by the system. – dan Dec 27 '15 at 23:24
  • If he puts Spanish first in the Language list, his OS will be in Spanish, but he wants it in English. – Tom Gewecke Dec 28 '15 at 4:06
  • I will check tomorrow how exactly I have it setup, but I have the OS in English and the Keyboard in Spanish ISO with no problems. Sorry for the misguiding of my answer, I promise to share a better one tomorrow. – Agusti Fernandez Pardo Dec 28 '15 at 4:32
  • I can't rearrange the input source, english is always first – IAmJulianAcosta Jan 11 '16 at 20:33
1

I solved a similar issue by deleting the HIToolbox.plist file after changing the keyboard layout under System Preferences.

rm -rf ~/Library/Preferences/com.apple.HIToolbox.plist
| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .