So I tried deleting an app a few days ago and it requires admin name and password. I tried every single combination that i can think of and it wouldnt work. I then realize that I have a standard user instead of an admin. I tried the create a new admin user way but the permission is denied. I got no idea how to proceed onwards. Help needed please. Its a osx yosemite 10.10.5

  • The first user you set up should be admin. Did you forget the password? You might be able to recover it. Have you set up a Firmware Password? If you don't know what that is, chances are you haven't, but I know someone who couldn't get into the admin account because he forgot the password and a computer "expert" set a Firmware Password.
    – Arc676
    Dec 27, 2015 at 8:49

2 Answers 2


To create a new admin user, you need to reboot into Single User mode once:

  • Boot to single user mode (⌘-S while powering on)
  • Run /sbin/fsck -fy
  • Run /sbin/mount -uw /
  • Run rm /var/db/.AppleSetupDone
  • Run reboot

After the reboot, the Setup Assistant should get displayed again (as for a new Mac) and prompt you to create a new user. This user will automatically have admin rights.

  • Creating a new user may be undesired as all the information the OP has may be in the first user. There is no real need to go through the process of copying all your information into a new user just for this dilemma. An easier fix may be the solution I posted as an answer here, which does exactly what the OP wants without altering anything else on their system.
    – Phoenix
    Dec 27, 2015 at 10:40
  • 1
    There is no need to copy anything. Once a new admin user is created, any user account can be changed into an admin account by this new user
    – nohillside
    Dec 27, 2015 at 14:44

I have seen that in rare occasions an admin account has been degraded to a standard user.

Under normal conditions, there is a fairly easy fix on getting it back to admin status.

Here is how:

  1. At startup, hold down Alt
  2. Select "Recovery HD"
  3. Once presented with the choice of options, choose menu "Utilities", then "Terminal"
  4. Type in resetpassword Enter
  5. In the resulting window, choose your startup volume (typically it is "Macintosh HD")
  6. Select "System Administrator (root)" from the dropdown underneath
  7. Give it a password in the fields below and click "Save"
  8. Restart your system (menu "")
  9. When logging in, choose "Other"
  10. Type in root as the user and the password you just gave it
  11. Once in the familiar environment, open "System Preferences" > "Users & Groups"
  12. Unlock the padlock to the lower left-hand corner
  13. Select your real user
  14. Click the option Allow user to administer this computer

Effectively, this will get your user back to admin status. Now, just log out and log back in with your user.

Keep in mind that the above requires that you have access to this volume. If you use FileVault, you will need to unlock it first using Disk Utility.

For security concerns, you may want to do the following few clean-up steps as well:

  1. Once back with your user, open "System Preferences" > "Users & Groups" again.
  2. Click on Login Options underneath your list of users
  3. Click on "Join" next to Network Account Server
  4. Click on "Open Directory Utility"
  5. Open the padlock here as well
  6. From menu "Edit", choose "Disable Root User"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .