7

When I compress a large directory in OS X, like 5-6 GB the resulting archive cannot be browsed in Windows / Total Commander. It hangs the app and stays at 100% cpu usage, like its trying to extract it or something. Does anybody know whats causing this? Smaller zips that have like 2-3 GB can be browsed instantly.

  • 2
    Probably something to do with the inability of the tools on the Windows side to handle files bigger than 4 GB. Unless you also have problems unpacking these files on OS X, you might get better answers on a Windows-focused site (or maybe on superuser.com). – nohillside Dec 26 '15 at 19:27
  • It's not just TC. Windows Explorer says the zip file is invalid. I tried creating the zip with TC, but then the zip file cannot be opened by "The Unarchiver" app on OS X. Then I tried the 7-zip program and the ZIP file created by it can be browsed in TC and gives no errors in "The Unarchiver". So I guess the 7-zip program is the way to go, but I'm still wondering what's up with those zip files created by OS X – ktie Dec 26 '15 at 19:33
  • Another weird thing is that "The Unarchiver" takes much longer to extract those OS X zips. It gives a "Preparing..." message first, then after a long time it begins extracting. Expanding them with double click is much quicker. There's def something wrong with how Mac compresses large folders – ktie Dec 26 '15 at 19:40
  • I've seen this issue as well. Eventually just ended up making a few zip files to transfer the data I needed. – wogsland Dec 30 '15 at 21:58
  • 2
    Just experienced such a problem: 7GB file zipped on Mac OS X. Another Mac can uncompress it, but on Linux, unzip -l or 7z l give errors. The same file compressed on Windows or Linux does not have this problem. – mivk Nov 25 '16 at 16:18
3

The built-in Archive utility on Mac OS X creates invalid Zip files when they are larger than 4 GB. This is still the case on Sierra (10.12.6).

In Windows 10, trying to open such a .zip file in Explorer fails, saying the file is invalid (which is true).

Current versions of Total Commander, 7zip and probably others have workarounds for this particular bug, and should be able to open and uncompress these large files.

Conclusion: do not create large .zip files (over 4GB) with the Mac built-in compressor but use some other tool instead.

For the gory details, see Apple Archive Utility (and ditto) and very large ZIP archives (which is, ironically, only available on archive.org since the original web site has shut down)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .