1

I have internet access but I noticed that in System Preferences/Network, although the W-Fi status is "On" this statement is below: "Wi-Fi has the self-assigned IP address XXX.XXX.X.XX and will not be able to connect to the Internet." There is a yellow dot preceding the "Wi-Fi / Self-Assigned IP" icon on the far left of the System Preferences/ Network window. The Network Diagnostics shows all the items under Network Status as green. My modem does not have a router. It is behind a Verizon (ISP) router that I do not physically own or have access to. I can only access the settings at: "my home.modem manufacturer's name.com". Is this still a problem that needs correcting? Thank you.

UPDATE: My ISP says: "Okay that's the issue as it is a 6100 modem it does not have a feature or wireless option you need to get one wireless router from ups store...I will send you a free modem which is an advanced one.."

MacBook Pro with Retina display, OS X Mavericks (10.9.5), MacBookPro11,3; Airport Time Capsule

  • 2
    If (for whatever reason) no IP address is assigned to it from outside, your computer will make up an IP address for its Wi-Fi to use locally. So I'm guessing you should use Airport Utility and examine what is going on in your Airport Time Capsule. – GEdgar Dec 26 '15 at 2:12
  • Your network hardware information is a bit vague. It is unclear which device provides the wifi for your device: is it your 'modem' connected to the Verizon router or the Verizon router itself? Have you powered cycle your 'modem'? Have you asked the owner of the Verizon router to power cycle the router? Sometimes, simple net connection glitches are fixed with a flick of the power switch. – IconDaemon Dec 26 '15 at 2:45
  • OP mentions no Time Capsule device - the yellow dot is in System Preferences > Network, indicating that the router serving a usable IP address is not working. – IconDaemon Dec 26 '15 at 2:48
  • Maybe it is an edit (but I don't see a history) but OP has Time Capsule listed last in hardware list. – bjbk Dec 26 '15 at 3:21
1

So there are two things happening when a wifi device wants to use "internet". First it has to join the wifi network using an AP (access point) If there is a password like WPA that needs to be supplied. Next the device needs to get an IP address. That information comes from a router. It is not always necessarily true that the router and AP are the same piece of equipment. If the IP address acquisition (typically via DHCP) fails or times out the device will assign itself an IP from 169.254.X.X. However this IP can never talk to the Internet and the device knows that so that's why the message is provided. Sometimes this is simply resolved via a reboot of the router, but it could also be a hardware failure, especially if the AP and router are two separate devices.

0

I would check Airport Utility to see what the problem is. If there is a yellow dot by the Time Capsule, that means that it is not properly connecting to the Internet. This means either the Ethernet cable is loose, or it is not configured properly. Try checking all cables or restarting the router, or try to reconfigure the Airport. If all fails, see this guide on Apple's website on resetting/troubleshooting the router.

If the Internet bubble is yellow and the Time Capsule is green, then your router is messed up and you need to contact the owner to reset it.

Hope that helps.

  • OP mentions no Time Capsule device - the yellow dot is in System Preferences > Network, indicating that the router serving a usable IP address is not working. – IconDaemon Dec 26 '15 at 2:48
  • Hmm. I was under the impression OP used the Airport Time Capsule for wifi. Then it would appear resetting the router would help. – SentientBacon Dec 26 '15 at 2:49
  • The first comment (by GEdgar) to the OP inserted a non-existant Time Capsule into the mix. I agree that resetting the Verizon router, and whatever the 'modem' is, will be a good first step in attempting a fix. – IconDaemon Dec 26 '15 at 2:52
  • Airport Time Capsule was there in the original post. It is at the very end. – GEdgar Jul 23 '16 at 14:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .