0

I have an app which is installed in OS X. It needs a certain software patch currently to make it run successfully in the latest OS, and we are sending the patch as a standalone separate app, which when installed, does the necessary things (mainly updating a Config file within the <MyApp>.app folder in /Applications). After this, double clicking the app icon in Finder launches it fine. But when we try to launch it by clicking the icon in the Launchpad, it doesn't open. (this is the problem which we are solving, it won't open even from Finder by double clicking without the patch).

So I tried to refresh the Launchpad by these things:

rm ~/Library/Application Support/Dock/*.db
defaults write com.apple.dock ResetLaunchPad -bool true; killall Dock
cd $TMPDIR../0/com.apple.dock.launchpad/db/ && rm db*

Nothing works. It still doesn't open. Only upon restarting the Mac does the Launchpad click work and the app launches.

Is it possible in any way to fix this without requiring a restart?

OS - Yosemite, El Capitan both.

1

I recently come up with the same question.

unlink Library/Application\ Support/Dock/desktoppicture.db
touch /Applications/YourAppName.app
killall Dock

the touch(1) command is very important. things would not work without it. I think maybe the Dock does not update its db unless the app was updated.

  • Nope. Doesn't work. It should be ~/Library by the way... – SexyBeast Jan 7 '16 at 16:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .