0

For some strange reason, and since a very long time, every time I open word, the keyboard is automatically changed to Japanese Hiragana. Obviously, being Italian, I do not at all want such an auto change. Is there any way to reverse this? Is this a Word problem or something related to the OS, or perhaps something to do with both?

Update

Following comments, I tried unchecking the box in Word > Preferences > Edit for "Match font with keyboard". No change, but I found out that the change takes place during the opening of Word, stays there while the Project Gallery is open, and is reversed as soon as the new document gets opened, so once the new document appears, the keyboard changes back to the correct US Extended keyboard.

Update copied from the forum

Neither the Normal.dotm, nor the Match font with keyboard box in Preferences>Edit, nor Tools>Language and selecting Italian, none of this did anything. This issue is mysterious...

Another copied update

The Language and Text thing (System preferences > L&T > put Italian at the top of the language list) did not work at all. Plus, I want my Mac to speak English, and this change makes System Preferences speak Italian, which I decidedly do not like. Which is why I reversed it.

  • If you don't get an answer here, try the forum devoted entirely to Word answers.microsoft.com/en-us/mac/forum/macword – Tom Gewecke Dec 24 '15 at 17:30
  • Did that. Let's see who answers first :). – MickG Dec 25 '15 at 13:42
  • In Word > Preferences > Edit, is the box unchecked for match font with keyboard? Is there any chance that the language of your default document has been marked as Japanese? – Tom Gewecke Dec 25 '15 at 15:22
  • @TomGewecke the box is checked. I have no idea. I can't quite see how that box could influence the setting since the documents I usually open are in Times New Roman which is decidedly not a Japanese font. Besides, that box is useful when checked, so when I type Chinese the font gets auto-changed appropriately. How do I verify the language of "my default document"? – MickG Dec 25 '15 at 15:30
  • FWIW the blank document I just created has English (US) as language. But could that have to do with my subsequent changing the keyboard back to US Extended? – MickG Dec 25 '15 at 15:31
0

Tom in the comments here was getting to it. Too bad John Korchok was quicker in replying over at the forum. He suggested this:

That means there is one last thing you can try. Please open Applications>Microsoft Office 2011>Additional Tools>Microsoft Language Register and open Microsoft Language Register. Check that the dropdown is set to English, then OK out and test Word once more.

And I commented on it with this:

Yep, that was it. Changed Japanese to English, and the keyboard change vanished. But the Phonetic Guide option also vanished… is there any way to have both no keyboard change and the Phonetic Guide? Because if I ever find myself typing Japanese, I might need that phonetic guide… Of course, if that ever happens, I can just reopen the register, but if there was a way of keeping the option even with the register saying English it would be great.

That was 2 secs ago so he hasn't had time to reply to the "would be great" part just yet :).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .