6

About a couple of weeks ago, the Guest user account was automatically enabled on my Mac running OS X El Capitan (by itself, without me enabling it). Now, whenever I start my Mac, I am greeted with a login screen showing two accounts: 1) Mine. 2) Guest user.

I have Find My Mac turned off, as I know people have suggested that the Find My Mac feature may be responsible for this behavior. Beyond that, I have logged out of my iCloud account from "System Preferences -> iCloud," and also disabled the Guest account from "System Preferences -> Users & Groups." Now it shows the Guest user as off in System Preferences.

However, when I start my Mac, I'm still shown two accounts to log-in. And yes, I have tried and have successfully managed to log into the Guest account despite having disabled it in System Preferences.

This is very strange, and I was wondering if anyone has found a fix.

Additional Info which may help: I've never had this issue with any other versions of OS X prior to El Capitan. And I've got FileVault enabled, and it's been enabled since OS X Lion without this issue.

I'd greatly appreciate any feedback.

  • Did you turn off find my mac before logging out? Did you disable the guest both in its account as well as general login settings? – John Keates Dec 24 '15 at 2:44
  • I turned of Find My Mac before I logged out. I also disabled the Guest account in System Preferences as an administrative user. Still haven't solved the problem. Do you have a solution? – John Dec 24 '15 at 18:42
  • Do you have FileVault on? – John Keates Dec 24 '15 at 18:43
  • This happened to me before, with Mavericks. I wipe my computer every 4-5 months are so though, so it is no longer an issue. It was infuriating though. – Flare Cat Jan 22 '16 at 1:53
1

After some extensive testing (and multiple Time Machine restores--to verify that this fix works), I have found a solution. And it's pretty easy too, just don't do it on the go, or you'll wipe out your battery.

  1. Visit Apple's dedicated website to download the OS X 10.11.4 Combo Update
  2. Disable Find My Mac
  3. Ensure that you have disabled the guest user Disable Guest User
  4. Install the combo update

Poof! Guest is gone.

  1. Re-enable Find My Mac, if you'd like.
  2. Disable guest user again, immediately after re-enabling Find My Mac

And that's it! It works nicely with FileVault 2, Bootcamp, and Time Machine, so no worries there.

  • You don't actually need to install the combo update... Since you've File Vault enabled your login happens pre-boot on the EFI... disabling the Guest User won't update the EFI login screen. I found a way to force it to update, read this: apple.stackexchange.com/a/232352/36313 . It should fix the issue. – TCB13 Mar 24 '16 at 20:24
0

Seems like a duplicate of another question, this answer should help you: Guest login got enabled even though FileVault 2 is enabled and Guest login is disabled

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .