I have this SD card that I am trying to use to backup photos on a Windows computer.

After using the SD card on the Windows computer, and copying the photos back on a safe drive, I cannot erase the SD card:

enter image description here

And yep, in the Info window for the card, the device is listed as "read only":

enter image description here

I checked the Lock Tab and it's not on Lock position... What gives?

  • Try executing: sudo chown <username> /dev/disk1, with <username> being your username. You might also try sudo chmod 750 /dev/disk1. These commands set the permissions, as permissions error might be the case, since the Info tab says you can only read
    – John K
    Commented Dec 24, 2015 at 0:49
  • Thanks! Tried, no luck. Terminal also doesn't seem to recognize my username...? MacBook-Pro:~ fabrice$ sudo chmod 750 /dev/disk1 Password: MacBook-Pro:~ fabrice$ sudo chown <fabrice> /dev/disk1 -bash: fabrice: No such file or directory MacBook-Pro:~ fabrice$ sudo chown <Fabrice> /dev/disk1 -bash: Fabrice: No such file or directory MacBook-Pro:~ fabrice$ whoami fabrice MacBook-Pro:~ fabrice$ sudo chdown <fabrice$> /dev/disk1 -bash: fabrice$: No such file or directory MacBook-Pro:~ fabrice$ Commented Dec 24, 2015 at 0:58
  • 1
    It does not recognize because you put the < and > signs in. If I were to username I'd do John not <John>. So sudo chown fabrice /dev/disk1
    – John K
    Commented Dec 24, 2015 at 0:59
  • Oh! Ok, gotcha - sorry. I tried both command lines and neither did work - still can't erase in Disk Utility and SD card still read only in the Info Window Commented Dec 24, 2015 at 1:03
  • Since it is not the lock issue, try first diskutil unmountDisk /Volumes/UNTITLED and then try erasing the partition. Sometimes, you can also select the hardware APPLE SD CARD READER, going to partitions, and selecting from current, to 1 partition, formatting and applying. Should delete, and re-add a partition
    – John K
    Commented Dec 24, 2015 at 1:05

6 Answers 6


A better and simpler solution would be using the command-line.

Execute the following command to identify the mount name of SD card following the pattern /dev/diskX, e.g., /dev/disk2

diskutil list 

Say the disk name is /dev/disk2. Now format the card to FAT32 by running the following command:

sudo diskutil eraseDisk FAT32 MYSD MBRFormat /dev/disk2
  • 1
    This worked for me after Disk Utility failed and so did the SD formatter application below. Thanks! Commented Aug 4, 2018 at 16:16
  • 1
    Perfect, worked great. One thing to note is my SD card had partitions from a Raspberry Pi NOOBS install, and the OSX UI Disk Utility would only show the small (59mb) partition and not the large (16.0gb) partition. CLI worked - I needed to specify the partition scheme disk6, not disk6s1 or disk6s2 in this case.
    – SeanCannon
    Commented Jan 23, 2019 at 1:29
  • Successfully deleted all files from my SD card But, after that when I mount the SD card all data is restored. How do I fix this.
    – Vineesh TP
    Commented Jun 11, 2020 at 17:37
  • 1
    When I try this, gettig this error in terminal, Error: -69830: This operation requires an unmounted disk
    – Vineesh TP
    Commented Jun 11, 2020 at 17:44
  • @VineeshTP I got a similar error :/ Error: -69825: Wiping volume data to prevent future accidental probing failed
    – Joe
    Commented Jan 10, 2021 at 15:52

I had the same exact problem. Format your card using this application: https://www.sdcard.org/downloads/formatter_4/index.html

Worked perfect for me.


  • 1
    SDFormatter, that's the ticket! Commented Jan 7, 2017 at 0:07
  • MacOS disk utility and diskutil command didn't work. I installed this application. This application reported that write-protect was enabled for my device. I disabled write protect and tried using MacOS disk utility. And it worked. Thanks Sd Card Formatter :)
    – Halil
    Commented Jul 9, 2018 at 8:09
  • 1
    Not worked for me.
    – Vineesh TP
    Commented Jun 11, 2020 at 18:00
  • Well there goes all my hope. Nothing else worked and this didn't either: "[ERROR] Failed to read existing main OEM parameters from device: 60 (Operation timed out) Formatting failed!"
    – Jozey
    Commented Oct 22, 2023 at 18:37

I had to run

sudo diskutil eraseVolume exFAT MYSD MBRFormat /dev/disk2s1

to successfully format a volume on my 64G SD card.

  • 3
    The third parameter does not appear to be "bootable" or "nonbootable". So chnaged eraseVolume to eraseDisk . but , Error: -69830: This operation requires an unmounted disk.
    – Vineesh TP
    Commented Jun 11, 2020 at 18:02

For a reason I haven't yet understood, the card was erased just fine once I used an older version of Disk Utility.

When I inserted the SD Card in a computer running Yosemite, two drives mounted, one called "NO NAME" which I could click on, and one called "UNTITLED" which seemed to be a ghost file or an alias:

enter image description here

When using Version 13 (606) of Disk Utility (so, the version included with Yosemite), the SD Card was erased without any problem.

The ghost "UNTITLED" drive disappeared.

I am therefore led to believe that the new Disk Utility in El Capitan doesn't work the same way as the previous one, or that it failed at erasing the card in this particular situation.

  • 1
    Version 16 worked for me whereas version 18 did not. Thanks for the tip.
    – bergie3000
    Commented Nov 4, 2019 at 2:03

I faced the same issue. I tried with 8GB, 16GB and 32GB cards and none worked. The trick was in the SD card reader. On the left side there was a switch for physical write protection. Toggling the switch and reinserting the card worked!!

  • This was the issue in my case. Thanks! Error: -69877: Couldn't open device is the error I was getting Commented Sep 13, 2020 at 3:28

I tried a different SD card reader, and that fixed the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .