3

I use same Apple ID on different Macs (used by different people), only to use Find My Mac.

So I disabled Message, Facetime etc. – App Store updates are still a bit problematic since I don't want to share the account password.

We also use Drop boxes to share files, so everyone has enabled public file share of Public folder.
But since El Capitan (or Yosemite), all computers is accessible to everyone, because they connect themselves with the Apple ID (instead of connecting as Guests), and not only Public folder but also HD and Home folder are visible. (And I see the apple ID as "Connected with".)

How can I disable that?
And is there a better management of Apple IDs (I want to avoid a per-device ID)?

Thanks!

7
  • 2
    Apple IDs are supposed to be 'per person'. It barely works with husband & wife, it really won't for a company.
    – Tetsujin
    Dec 22, 2015 at 19:05
  • @Tetsujin But I can't figure out what is the recommandation for this kind of situation: one account per new computer, even if different people use them? Thanks
    – Joan
    Dec 24, 2015 at 11:32
  • Apple has a dedicated 'for Business' structure - though it's not one I've used so you'd need to do some research. A couple of links to get you started - apple.com/business/vpp & maybe discussions.apple.com/thread/5063144?start=0&tstart=0
    – Tetsujin
    Dec 24, 2015 at 11:38
  • Read these in the past (before 10.10 and ID-allowed sharing) and a single account was still easier. Maybe it's time to check this again. Thanks!
    – Joan
    Dec 24, 2015 at 11:42
  • Welcome - wish you luck :)
    – Tetsujin
    Dec 24, 2015 at 11:42

2 Answers 2

5

Joan, try this (it worked for me):

  • Log in as a different user than the one you want to modify; also, make sure the account you want to modify is not logged in.
  • Open the Users & Groups pane of System Preferences.
  • If the lock icon in the lower-left corner of the Users & Groups window is “locked,” click it and provide an administrative username and password when prompted. This allows you to make changes.
  • In the list of accounts on the left, right-click (or Control-click) on the name of the account you want to modify, and then choose Advanced Options from the resulting menu.
  • Look inside the box that says "Aliases". If your apple ID is listed there, delete it.
  • Then close the padlock, and that did it for me. If computers connect via the Apple ID now, all they can see are the shared, public folders. Nothing else.

Hope it works!

3
  • Nice “advanced options” trick – no aliases, but I removed Apple ID association… but it disable iCLoud, and Find My Mac. If I set it back, account is associated with Apple ID again. Didn't had to change user though.
    – Joan
    Jan 12, 2016 at 11:24
  • Looks like disabling association and remove aliases, reconnect iCloud through iCloud panel (and not Web account), and back in users panel remove aliases only… do the trick. I'm tryin it on other devices.
    – Joan
    Jan 12, 2016 at 11:38
  • At least under 10.14, there is a separate "Apple ID" field above the Aliases field. Check all user accounts for Apple IDs: more than one can be signed into the same id.
    – Seth Noble
    Jun 8, 2020 at 18:37
0

If you aren't liking the effects of Find My Mac, you might look into the screens app. It works very well for me, but it won't change the fact that any administrator of a Mac can remotely log in.

It just lets you locate your account on a Mac when you are still logged in.

If you don't want to install software, you would need to look into a VPN to get your remote computer on the local network and using Remote Desktop app or Screens app (iOS or Mac) to connect to the "local" machines your account is allowed to log in remotely.

--

As a side note, you can always remove the sharing of your home folder - I learned the command line version from here: https://support.apple.com/en-us/HT203998 but you can use the System Preferences graphical sharing interface as well. Select your home folder under shared folders and press the - button.

sudo dscl . -delete "/SharePoints/Your User Name's Public Folder"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .