4

iTerm2 has a very nasty habit of making an assumption of what I want to copy and paste from the terminal. Instead of just allowing me to copy exactly what I highlight, it will expand to what it considers more useful.

As an example maybe I have the following command

rsync <file> server.example.com:/home/user/<file>

If I was to select via cursor and highlight server.example.com, it will instead re-highlight the entire command and copy that. It is so annoying because I copy stuff all day long.

I copy by either pressing Command+C, or right clicking to get the dialog menu and selecting copy which is the same as doing “Edit” → “Copy”, on the toolbar.

I have disabled the automatic select text and copy function. That is something I do not want enabled.

Is there anyway to fix this?

  • What version of iTerm2 are you using, and what version of OSX? This works fine for me. – Joe Casadonte Feb 12 '16 at 2:24
  • Hi @JoeCasadonte I am using the most up to date versions. So for iterm it's 2.1.4 and for OSX it's 10.11 – Biff Feb 16 '16 at 4:49
1

If you do a double-click to select it go into "all-word" mode, which automatically grabs each word.

If you just click and drag it'll take whatever your selection is.

  • 1
    Hi @Alex, well that's the thing that's not how it's working. I will click and drag and then before I go to copy by wither command+c or just right clicking it will select out as if I did the double click mode. – Biff Dec 23 '15 at 4:52
  • this is the wrong answer. – Biff Feb 16 '16 at 4:50
1

If you go to Preferences ( ⌘ + , )

Under the Appearance Tab, there is an option "Show tabs in fullscreen by holding ⌘ for:" and there is a slider from 0 - 10 sec.

I had the option set at 0 sec and was getting the issue described here. When I set the slider to 10 sec, this was not an issue.

I like being able to see the tabs, but do not like it messing with my copy selection, so I went with 1 second, enough time for me to copy the text without it fudging with my selection and showing the tabs.

0

It is an option under Preferences>General>Selection. I am using iTerm Build 3.1.6.

enter image description here

  • That's not really what I was looking for. – Biff Aug 11 '18 at 1:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .