1

I have been trying to set my external hard drive to ignore ownership in permissions, but I can't seem to do it. I am trying to enable the ignore ownership option because I am trying to run Xcode from my external hard drive. When I start Xcode, it gives me this error message:

Xcode is running from a volume that does not support ownership. Please move Xcode to one that does.

After searching Google and some other websites, I have came to the conclusion that I need to change the permission of the external hard drive to ignore ownership. This option should be under the 'Sharing and Permissions' tab according to some Internet sources. I have looked for a lot of different methods to change the permissions, but none of them have seemed to work for me. One particularly popular method was to select the drive, press Command+I (Get Info), and to change the permissions by clicking the lock in 'Sharing and Permissions'. When I select my drive, however, I do not get those options. In the image below, you will see that I do not have a lock or the other options that should be in that section.

I also have tried a number of commands from the Terminal, but I haven't gotten anything to work. I have tried 'sudo', 'vsdbutil', and a few other methods, none of which have worked.

Please let me know if it is not possible to have Xcode run from an external hard drive. If I can, any help as far to getting Xcode to run would be much appreciated. Thanks in advance!

Get Info Window from the external hard drive I'm using: Get Info Window from the external hard drive

EDIT: bjbk pointed out that in the screenshot above, it shows the format as MS DOS (FAT 32). In Disk Utility, it shows Mac OS Extended (Journaled). I formatted it as Mac OS Extended.

Drive Format

  • The drive is formatted for Windows. I believe Xcode needs to be installed on a Mac formatted drive. If you need a portion to be Windows friendly, create a OS X partition for Xcode. – bjbk Dec 22 '15 at 1:09
  • In Disk Utility, it says that the disk is formatted in Mac OS Extended (Journaled). – Rane1011 Dec 22 '15 at 1:47
  • In your screen shot it shows as MS DOS (FAT-32). – bjbk Dec 22 '15 at 1:50
  • Yeah... I don't know why. Would you like me to add a disk utility screenshot? – Rane1011 Dec 22 '15 at 1:51
  • That would be useful. – bjbk Dec 22 '15 at 1:52
1

The partition that Xcode is installed on must be formatted for OS X. This will require reinstalling Xcode after formatting. Be sure to save any important files from the drive elsewhere.

In Disk Utility, choose the partition and select erase.

Format the partition then reinstall Xcode.

This should resolve the ownership issue.

It appears from your screenshot that the partition cannot be modified. You mention in your comment that the partition "has all of the external drive memory allocated to it." Not sure what you mean here, are you using it for other purposes too? If not, and you don't have another drive to use, in order to use this drive instead of the default installation on your main drive, it seems you have to reformat the drive.

  • I mean that the current partition has 1 TB allocated to it. My drive is 1 TB, so I didn't know if I could add another partition if the current one was already "taking up" all of the drive's memory. I think I will just erase the drive and reformat. Format it to OS X Extended (Journaled), right? – Rane1011 Dec 22 '15 at 2:33
  • Yes, you won't loose anything if it is empty anyway – bjbk Dec 22 '15 at 2:34
  • Ok. Thanks for all of your help and being so patient with me. – Rane1011 Dec 22 '15 at 2:37
  • It's a pleasure! We all learn from each other! – bjbk Dec 22 '15 at 2:38
0

You can use terminal to change this option:

sudo diskutil enableOwnership <disk_indentifier>

With diskutil list you can find the right disk indentifier.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .